17 Replies Latest reply on Nov 8, 2011 12:41 PM by Peter Spier Branched to a new discussion.

    Page numbering

    highshore13

      I have spent more than half a day tryinbg get sequential numbering in a 245-page document, starting with page nine of the document being designated as 1.  I have read all the manuals, the books, Dummies, the Help line and still cannot get this done.

      I have since converted it to a Book and still no joy. Simply I want the first eight pages unnumbered and then start the book/dcument on page 9 numbered as 1 and the rest to follow in seqauence. Can I do this? NO!  It's driving me crazy. Life should be simpler than this.  Any easy answers?

        • 1. Re: Page numbering
          Colin Flashman Adobe Community Professional

          indesign can't have no numbers as such, there has to be some sequence to the pages so that the software knows that page X follows page Y for example. however, something such as roman numerals can be assigned instead for the first eight, and then regular numbers for the remainder.

           

          start off on page 1 and go to layout/numbering and section options. from the style dropdown in the new dialog box, select the roman numerals (i, ii, iii etc) and click OK.

           

          next, go to page ix and again go to layout/numbering and section options. from the dialog box, go click the checkbox "start page numbering at:" and make sure the first number is 1. make sure the style dropdown is normal numbers.

           

          if the OP is still having trouble, go to the preferences/general and make sure in the page numbering dropdown that "section numbering" is selected rather than absolute numbering. this one rather hidden option can be a huge source of frustration

          • 2. Re: Page numbering
            Peter Spier Most Valuable Participant (Moderator)

            And make a second master page without page number markers to apply to those pages that you don't want to see a number on.

            • 3. Re: Page numbering
              highshore13 Level 1

              Thanks butI done all this and stillnothing appears on the actual pages. It will not accept any page numbers. There must be a simple solution but I can't find it after a whole day's struggle.

              • 4. Re: Page numbering
                Peter Spier Most Valuable Participant (Moderator)

                I've moved your question to its own thread, but becasue you replied to someone above your first post the last response did not move with it. I will, however continue in the new thread: http://forums.adobe.com/thread/922742

                • 5. Re: Page numbering
                  Peter Spier Most Valuable Participant (Moderator)

                  OOPS, I'm getting confused about who is who, here. Disregard the last post.

                   

                  Did you put a text frame on the master page that has a current page number marker in it? That's how ID does automatic page numbering on you document pages.

                  • 6. Re: Page numbering
                    highshore13 Level 1

                    Yes, I have drawn text frames galore all day long and inserted page numbers on master pages. But they either don't appear on the document when applying master pages or it is just the same two numbers applied right through the entire document. There must be one vital step I am missing.

                    • 7. Re: Page numbering
                      Peter Spier Most Valuable Participant (Moderator)

                      The page number marker is a special character that you must insert: Type > Insert Special Character > Markers > Current Page Marker (also available from the right-click context menu or by keyboard shortcut). On the master page it will appear on the page with the prefix letter assigned to the master, but will show the logical page number assigned on the document pages.

                      • 8. Re: Page numbering
                        highshore13 Level 1

                        Yes, done all that ages ago.  I think I have done everything as per instructions.  So frustrating. Thanks for your tolerance and persistance.

                        • 9. Re: Page numbering
                          Peter Spier Most Valuable Participant (Moderator)

                          Can you post some screen shots of your Pages panel, your master pages, and a document page where you think the number should be appearing, but is not what you expect (and put a note in red or something telling us which page number it is, or even better have that page selected in the Pages Panel when you make that capture). It will help to have frame edges showing, and any frame that should have the page number in it selected.

                           

                          Use the camera icon on the web page to embed images into your post like this:

                          CameraIcon.png

                          • 10. Re: Page numbering
                            highshore13 Level 1

                            This is just too complicated.  You are asking me to learn yet another procedure ijn order to solve what should be a simple operation. I am now totally lost.  I only want my document to be numbered from 1 to 246. When I try to attach master pages to the document  I get a message that "one or more of the pages specificed are not valid pages names".  Where#s the nearest madhouse ... I'll be right at home there.

                            • 11. Re: Page numbering
                              Peter Spier Most Valuable Participant (Moderator)

                              Take a deep breath. I'm just trying to get enough information to figure out what you are doing incorrectly. Clearly SOMETHING is not right, and my guess would be it's some sort of misunderstanding on your end rather than a program error.

                               

                              Would you like to send me the file to examine?

                              1 person found this helpful
                              • 12. Re: Page numbering
                                highshore13 Level 1

                                I fully appreciate all the help and patience coming my way.  I am overflowing with guilt.  The good news is that somehow or other I have managed to get the entire document numbered from page 1 to 246. 

                                I set up a completely new document, made master pages and cut and pasted the entire document from the previous disaster into this new version. It works - but I have no idea how or why.  Of course, The first eight pages, which should be unnumbered (or numbered differently) are included in the total numbering. But I guess I'll just have to live with that.

                                I can't tell you how grateful I am for your patience and guidance.  I will now persevere with learning the sytem (hell, I'm not a complete novice and am producing magazines using InDesign) and will try to make sure this never happens again. Thanks Peter. Tony

                                1 person found this helpful
                                • 13. Re: Page numbering
                                  Peter Spier Most Valuable Participant (Moderator)

                                  It's possible the original file was corrupt -- not common, but it happens.

                                   

                                  Want to try fixing the numbering again? Right click in the Pages panel on the page that should be #1 and choose Numbering and Section Options, then Start Section and set to start at 1. ID will immediately complain that another page already has that number, so right-click the icon for the first page in the doc, go back to section and numbering, and cahnge the numbering style inthe dropdown to anything other than what it is currently.

                                   

                                  Those pages that should show no number should either use a differnt master page with no number marker (best), or you can individually override and remove the number frames on the pages.

                                  • 14. Re: Page numbering
                                    CHANDERLI

                                    Here's how I deleted unwanted page numbers at the start of a document. First, make a copy of your document and play with the copy.

                                     

                                    Under "Edit/Preferences/General" set "Page Numbering View" to "Absolute."

                                     

                                    1. In the Pages Palette, right click on the first page of your document and click on "Override All Master Page Items" in the pop-up menu.

                                     

                                    2. Go to the actual page in your document and with the Text Tool delete the page number.

                                     

                                    Repeat the previous two steps for each page that you want unnumbered.

                                     

                                    Finally, go back to the Page Palette and right click on the page that you want numbered "1". Select "Numbering and Section Options." Click on the radio button next to "Start Page Numbering At:" and type "1" in the box. Make sure the "Start Section" box is checked. Click "OK"

                                     

                                    Look at your document to make sure the pages are numbered correctly.

                                     

                                    That's it.

                                    • 15. Re: Page numbering
                                      highshore13 Level 1

                                      Brilliant. It worked. Endless thanks.  I honestly don't think the file was corrupt - it was me being a complete dill.  Again, sorry for the trouble. I will now retire to the couch and take endless deep calming breaths.  Cheers, Tony

                                      • 16. Re: Page numbering
                                        Peter Spier Most Valuable Participant (Moderator)

                                        highshore13 wrote:

                                         

                                        I will now retire to the couch and take endless deep calming breaths.  Cheers, Tony

                                        An excellent plan. I hope now that you've seen it DOES work the rest of the week will go more calmly and smoothly.

                                        • 17. Re: Page numbering
                                          Peter Spier Most Valuable Participant (Moderator)

                                          CHANDERLI wrote:

                                           

                                          Here's how I deleted unwanted page numbers at the start of a document. First, make a copy of your document and play with the copy.

                                           

                                          Under "Edit/Preferences/General" set "Page Numbering View" to "Absolute."

                                           

                                          1. In the Pages Palette, right click on the first page of your document and click on "Override All Master Page Items" in the pop-up menu.

                                           

                                          2. Go to the actual page in your document and with the Text Tool delete the page number.

                                           

                                          Repeat the previous two steps for each page that you want unnumbered.

                                           

                                          Finally, go back to the Page Palette and right click on the page that you want numbered "1". Select "Numbering and Section Options." Click on the radio button next to "Start Page Numbering At:" and type "1" in the box. Make sure the "Start Section" box is checked. Click "OK"

                                           

                                          Look at your document to make sure the pages are numbered correctly.

                                           

                                          That's it.

                                          I have to say I think that's a TERRIBLE way to do things.

                                           

                                          First off, the whole point of viewing section numbering is so you can see waht logical page number is assigned to the pages in the pages Panel or the page navigation list. This is particularly important for books, where every document starts with and absolute number of 1, but could have any logical number depeding on where it falls inthe book.

                                           

                                          Second, there is pretty much NEVER a good reason to override all master page objects. If you want to delete one item, override that item. On Mac, Cmd + Shift + click on it with the Selection tool. On Windows it's Ctrl + Shift + Click.