8 Replies Latest reply on Nov 22, 2012 2:06 PM by bootsuk

    Title fades not linear in MPE

    jacobi1970

      The problem:

       

      Whenever using MPE as the renderer, my title and graphic fades exhibit a very steep attack. When switching to software mode, the fades behave correctly. I can compensate for the abrupt MPE fades when utilizing an exponentially growing alpha fade, but this is a very cumbersome approach if having lots of title/graphic fades and I would like to ask if other users have the same issues - perhaps it is an MPE bug with certain video cards? I really don't want to switch to the slow software mode just to have those perfect fades ;-) The issue is identical with both a GTX 470 and a GTS 250 (the first officially supported - the last not supported, however it works flawlessly with the hack). I have the latest Nvidia drivers installed and CS 5.52

       

      Best, Jacob

      MPE-bug.jpg

        • 1. Re: Title fades not linear in MPE
          Jim_Simon Level 8

          It's not a bug, it's just the way MPE is designed to work.  It happens for everyone.  And the only way to stop it is to use Software mode.

          • 2. Re: Title fades not linear in MPE
            Colin Brougham Level 6

            This is a known "issue," if you will--though it's not really an issue, or at least not a bug. This is part of the design of the hardware-accelerated (GPU) Mercury Playback Engine. By the way, you're always using MPE, whether you're in software or hardware rendering mode. Read these for more on that subject: CUDA, Mercury Playback Engine, and Adobe Premiere Pro and Adobe Premiere Pro CS5.5 improvements in CUDA processing and the Mercury Playback Engine. These pages will also help you understand a little bit about the difference between the rendering modes.

             

            Basically, enabling hardware-accelerated rendering also enables rendering in 32-bit floating point linear color. "Linear color" means that color is processed more in a manner that is akin to the real world and how light interacts there. From the first article above:

             

            When rendering is done on the CPU with Maximum Render Quality enabled, processing is done in a linear color space (i.e., gamma = 1.0) at 32 bits per channel (bpc), which results in more realistic results, finer gradations in color, and better results for midtones. CUDA-accelerated processing is always performed in a 32-bpc linear color space. To have results match between CPU rendering and GPU rendering, enable Maximum Render Quality.

             

            Unfortunately, it makes dissolves "pop" in the manner you're describing--though I should note that your graph curve representations of the effect are not correct. For hardware MPE, the curve actually looks like the straight line you drew for software MPE; software MPE creates a logarithmic curve, which kind of looks like the one you drew for hardware MPE, but faces the other direction. In other words, the transition starts out slowly and builds up "speed" toward the end of the transition.

             

            I've lamented this and battled it for a long time. Read Battling Hardware MPE, Episode 2: Chunky Blurs for my tests, and there's some more detail and images in Opacity Curves and MPE+GPU.

             

            Bottom line: this is The Way It Is with hardware-accelerated MPE. There is no way to turn it off, short of switching to software only rendering, but that gives up all the other benefits of hardware MPE. While you could turn on Maximum Render Quality in the Export settings to increase the quality of scaling and the like, guess what: that enables linear color processing, too.

             

            Personally, I'm pretty disappointed that Adobe has locked us in with this all-or-nothing approach to the benefits of hardware-accelerated rendering. I've had clients notice it, and they don't like it, so I have to use software rendering in those cases--that means lost time and aggravation. If you're game, definitely file a feature request for more control over this aspect of Premiere Pro: Adobe Feature Request/Bug Report Form

            1 person found this helpful
            • 3. Re: Title fades not linear in MPE
              jacobi1970 Level 1

              Thank you so much for your explanations. I will definately make a feature request.

               

              Best, Jacob.

              • 4. Re: Title fades not linear in MPE
                Colin Brougham Level 6

                You're welcome...

                 

                By the way, you could save keyframed Opacity effects as effect presets, if you like. That way, if you get an Opacity ramp that works to sort of recreate the logarithmic curve in the linear color space, you can quickly apply it to a clip. Just keyframe Opacity on a clip, right-click the "Opacity" effect title, and select "Save Preset." You can define them for both incoming transitions ("Anchor to In Point") and outgoing transitions ("Anchor to Out Point"). I've got a few set up of different durations, e.g. 15 frames, 30 frames, 60 frames.

                • 5. Re: Title fades not linear in MPE
                  jacobi1970 Level 1

                  Perfect suggestion - I totally overlooked that feature in Premiere.

                  • 6. Re: Title fades not linear in MPE
                    pejaka Level 1

                    Whatever the explanations are, I think it is a bug. Somehow when using Blend Mode Normal the transparency does not behave normally. If you like to have title with 10 % opacity, it should be 10 % with both hardware and software mode. Now it is not!

                    I made a test with white text on a black backround. Screengrabs attached. (Software mode seems to have little gamma problem, R and B channels are little higher). Screen mode is useful only if you have white titles without borders, otherwise Colin's suggestion with effect presets are good workaround.

                     

                     

                    Pena MPE_opacitytest.jpg

                    • 7. Re: Title fades not linear in MPE
                      Jim_Simon Level 8

                      you could save keyframed Opacity effects as effect presets

                       

                      http://forums.adobe.com/message/2426130#2426130

                      • 8. Re: Title fades not linear in MPE
                        bootsuk Level 1

                        I'm only a novice but had the same problem with the fades etc.  I tried keyframes and much the same till I changed the blend mode to hard light then got a much smoother fade.  (CS6)