3 Replies Latest reply on Mar 26, 2012 2:13 PM by AFincher

    iOS Application "Failed to Install" -- Air 3.0

    neoX286 Level 1

      I'm having the hardest time getting iOS applications to install on my iPhone.  Every time I build my application it trys to install it on the device before coming back to say 'failed to install' on the phone.

       

      I tried pulling out all the code related issues and started a brand new Hello World project with one label in it.  I managed to get that to install once, but then it failed after that every single time.

       

      NOTE: I'm running this on a windows machine, as I don't have funding to purchase a mac box

       

      Here's the steps I took:

      1. Got a cert request from OpenSSL

      2. Uploaded the request to the provisioning portal

      3. Downloaded the actual cert

      4. Used OpenSSL to convert the cert to a .PEM

      5. Used OpenSSL to convert the .PEM to a .P12

      6. Added my device UDID to the provisioning portal

      7. Added my application id to the provisioning portal

      8. Got a provisioning file for that setup

      9. Built my application using the provisioning file and cert

      10. Copied the provisioning file to iTunes

      11. Copied the application to iTunes

      12. Synced the phone, it tries to install, and then the phone states 'HelloWorld failed to install' and removes the icon from the desktop

       

       

      I have no idea what I'm doing wrong here.  I'm going to try using my coworkers mac to build a cert on his machine instead and utilize that but I doubt that will resolve the issue.

       

      I haven't touched anything in the application descriptor at all, except for setting the applicationId to my application profile on the provisioning portal (as it won't build without that)

        • 1. Re: iOS Application "Failed to Install" -- Air 3.0
          neoX286 Level 1

          Well I got it to install again by fully starting up a brand new project, rebuilding it, and then syncing it.  I'm not sure why it worked  this time when I did it but I'm going to mess with it some more this weekend and see if I can continue to make updates to that application without it breaking again.

          • 2. Re: iOS Application "Failed to Install" -- Air 3.0
            neoX286 Level 1

            Issue resolved.

             

            Turns out, with iOS deployment, you cannot utilize embed data that is stored in your src folder.  (i.e. if you have a GFX or Fonts folder in the src directory or a sub package that you use to embed data in your application, move all of that data outsid of your 'src' folder in it's own folder outside of that instead instead.)  The embed tags just need to be updated to point to the right location, but iOS won't let you install the application on the device in this scenario.

            • 3. Re: iOS Application "Failed to Install" -- Air 3.0
              AFincher

              Hey Neo,

               

              I believe I've been having the same problem as this, I even created my own thread not having found this one.

               

              I very much did have my resources folder directly under source but have now moved it to be on the same level as source

               

              i.e.

               

              Project

              - src

              - resources

               

              instead of

               

              Protect

              - src

                 - resources

               

              But it's still have the Failed to Install problem. Is my project structure still incorrect with this or do I have to start another project and do it all again? It almost seems as doing it once corrupts the entire project.

               

              Thanks

               

              Aaron