0 Replies Latest reply on Nov 11, 2011 12:11 PM by kelleygirl80209

    https, amf, load balancer

    kelleygirl80209

      Environment

       

      - Flex 2.0.1

      - AMF/Remote Objects to Java app

      - Load Balancer/SSL accelerator (strips SSL before gets to app server)

       

      Would like to be able to support QA and Production with single build if possible, but not necessary

       

      remoting-config.xml

       

      <default-channels>

          <channel ref="my-secure-amf"/>

          <channel ref="my-amf"/>

      </default-channels>

       

      services-config.xml

       

      <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">

          <endpoint uri="http://{server.name}:{server.port}/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>

          <properties>

              <add-no-cache-headers>false</add-no-cache-headers>

              <polling-enabled>false</polling-enabled>

          </properties>

      </channel-definition>

       

       

      <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">

          <endpoint uri="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint"/>

          <properties>

              <add-no-cache-headers>false</add-no-cache-headers>

              <polling-enabled>false</polling-enabled>

          </properties>

      </channel-definition>

       

      The Issue

       

      The issue is that the client needs to talk https, but it's converted to http by the LB prior to sending to our server. I've read solutions that indicate that the endpoint class for the secure connection should be the non-secure class name:

       

      <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">

           <endpoint uri="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.AMFEndpoint"/>

       

       

      but when I do that, I get this message on my app server startup:

       

      flex.messaging.config.ConfigurationException: Invalid channel endpoint URI, https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure, must begin with http.

       

      I see some references for FDS 201, getting hotfix build 168076. I can neither find that specific build nor do I know whether that is part of hotfix2 or hotfix3. An attempt to contact Tech Support for this build this morning was comical (went in a circle 3 times and then ending up getting a phone number for a fee-based tech support line).

       

       

      Thoughts