3 Replies Latest reply on Nov 28, 2011 5:53 AM by whwi999

    rtmfp flash <=11.0 and flash 11.1 not compatible

    whwi999 Level 1

      hello

       

      i have a new problem with flash 11.1 (rtmfp multicast netgroup)

      when i broadcast my camera with flash 11.1 i can play the video with 11.1 but not with < 11.1 flash version

      when i broadcast with 11.0 i can not play the stream with 11.1 :-/

       

      is this a know bug or feature?

       

      the poroblem is client conects to neigbours this works but no downloading or uploading

      the player state is always buffering

       

      i test with latest strobe 1.6 player and simple flex rtmfp netgroup multicast flex player same results

      version: 11.1.102.55

      test on linux and windows same problem

      best regards

        • 1. Re: rtmfp flash <=11.0 and flash 11.1 not compatible
          Michael Thornburgh Adobe Employee

          are you using Flash Media Server?  if so, you must update to FMS 4.0.3 or 4.5 (or above). Flash Player 11.1 changes the communication protocol with the server over the group "server control channel", FMS 4.0.2 and below don't understand the new handshake protocol.

           

          the Cirrus service understands all versions of the group server control channel handshake. if you're using Cirrus, i'll have to look into this, but last time i checked (which was a little before the 11.1 release) P2P multicast still worked between all versions of Flash Player.

          • 2. Re: rtmfp flash <=11.0 and flash 11.1 not compatible
            Michael Thornburgh Adobe Employee

            i just tried the following combinations:

             

              1. publish from 11,1,102,55 subscribe on 10,3,183,5 and 11,0,1,152

               2. publish from 10,3,183,5 subscribe on 11,0,1,152 and 11,1,102,55

               3. publish from 11,0,1,152 subscribe on 10,3,183,5 and 11,1,102,55

             

            (all using a Cirrus server, a simple MXML app [not OSMF], and a simple groupspec and P2P multicast)

             

            all three combinations worked for me, although i had to reload the SWF to get access to the camera after it had been used by another process in a couple of instances which i didn't fully catalog.

            • 3. Re: rtmfp flash <=11.0 and flash 11.1 not compatible
              whwi999 Level 1

              hello

               

              i confirm works fine with cirrus but not with fms 4.5

               

              best regards