3 Replies Latest reply on Feb 6, 2012 2:07 AM by LineEffect

    Flash Builder 4.5 problem

    Echysttas Level 1

      Hello everybody.

       

      I'm hoping at least somebody has a similar problem: Flash Builder 4.5 and Windows 7 x64 with Flash Player 11.

       

      I try to launch a Flex Project in the browser but I get this message:

       

      C:\Windows\System32\Macromed\Flash\NPSWF64_11_1_102.dll

       

      Flash Builder cannot locate the required debugger version of Adobe Flash Player. You might need to install the debugger version of the Flash Player or reinstall Flash Builder.

       

      Do you want to try to debug with the current version?

       

      Apparently FB 4.5 looks for the 64 bit version of the NPSWF*.dll file, but I searched on my entire computer and I only find the "NPSWF32.dll" file, not the 64 one.

       

      Note: I have the *DEBUG* version of the Flash Player installed on FireFox 7, but it is indeed the 32 bit version because there ARE NO 64 BIT VERSIONS. Or at least none that I know of.

        • 1. Re: Flash Builder 4.5 problem
          Ansury Level 3

          I'm on Win7 64 bit with FB 4.5 and FP 11, and debug works fine.

           

          You may have the 32 bit debug player installed now, but try reinstalling the 32 bit debug player anyway.  If you're desperate, you could try renaming that 64 bit dll, copy a same-named 32 bit dll in it's place, and see what that does.  I used to do something similar to this when the security idiots where I work would push out new versions of FP all the time (although now I forget what I did specifically, I know it worked at the time).

           

          I'm thinking that re-installing the (32 bit) debug player will restore "something" that's causing your browser to point at the wrong Flash player version.  You could also try switching browsers (try Chrome).  If you're using IE 64 bit...well, don't.  It's not a Flash Builder problem, it's a browser plugin problem.

          1 person found this helpful
          • 2. Re: Flash Builder 4.5 problem
            Echysttas Level 1

            I tried renaming the DLL and it didn't give errors any more, but it won't launch either. It said something about some "delegate".

             

            But then I restarted FireFox and Flash Builder and IT WORKED ::- D. *laugh*. That's crazy!!! Absolutely unbelievable how such a nasty hack could work.

             

            This is obviously a bug in Flash Builder. They are asking for the wrong DLL name based on my OS or something like that.

             

            Anyway, thank you!

             

            I think I'm going to report this bug.

            • 3. Re: Flash Builder 4.5 problem
              LineEffect

              May be you have installed the 2 Versions of the Flash Debugger for IE and for other browsers.

              to Fix this just go to C:\Windows\System32\Macromed\Flash\FlashUtil64_11_1_102_Plugin.exe  then uninstall this Version

              then again install the Debugger you will use, Don't install both

              and i think everything will work fine after this

              Thanks