7 Replies Latest reply on Nov 19, 2011 10:29 AM by RenéHuwaë

    Precomp "losing" quality on the parent comp

    Eliminateur

      Hello,

      i've noticed an oddity after placing a couple layers in a precomp in that it looks "blurred" and has "jagged" edges on the main comp, but if i open the precomp it looks ok, the same problem happens after i render the output.

       

      The precomped layer is simply two non-transparent 24 bpp PNGs (some rendered text on a black background) that have some transforms applied to the position and rotation, no other effect is present.

       

      When i see it in the main comp one of the blocks shows white jaggies around it (the transform drops one of the blocks and rotates it like a falling billboard), and if i compare the comp windows to the precomp, it's clearly blurred.

      i've googled and saw something about collapse transformations, i set it in the main comp for the precomped layer to no avail.

      i also tried with color-keying the black BG in the precomp, the result is that in the main comp the image expanded to the left and had some ugly artifacts inside the letters.

       

      these are cropped parts of the workarea, first the comp view with the distortion jaggedness and after that the precomp window(it's hard to see you might need to zoom in):, even then it's clear that the comp is blurred

      jags.pngnojagsprecomp.png

      i've turned off all preview tricks, working at full resolution, no avail...

      i used this same precomp on another project (from which i imported it) which uses the same resolution and framerate and i wasn't seeing that issue there

        • 1. Re: Precomp "losing" quality on the parent comp
          Rick Gerard Adobe Community Professional & MVP

          It would be easier to diagnose with a screenshot of your project but I suspect that the quality setting of the layer in the pre-comp is set to draft, or that collapse transformations is off somewhere. You could also have a Pixel Aspect Ratio problem if the png files are a standard non square pixel frame size. You could also be having an open GL problem. Have you tried turning it off. You should also check a single frame render (as a Photoshop file for example) to see if it's a preview only issue.

           

          If you still can't figure it out post a screenshot of the main comp and the pre-comp and we'll take a closer look.

           

          One last thing. Are you using the transform effect or just animating the layer transform settings?

          1 person found this helpful
          • 2. Re: Precomp "losing" quality on the parent comp
            Eliminateur Level 1

            i've checked both layers in the precomp and they're set to high quality, same as the precomp aulity in the comp itself, also disabled opengl completely in preferences and the jaggedness remains.

            About the PAR of the png files, haven't checked, they're a random convenient size each one(quite big, 4.18mpx~).

             

            just animating the layer transform setiings in the precomp, here's the captures, comp and precomp:

            comp.pngprecomp.png

            the single frame render output of this same frame:

            master labios 28-10 (0-00-01-15).png

            • 3. Re: Precomp "losing" quality on the parent comp
              Rick Gerard Adobe Community Professional & MVP

              It looks like your rendered frame is fine, at least judging by the tiny screen that I'm looking at. I think you may have a display issue. I'm not seeing the problem in the screenshots you posted.

              • 4. Re: Precomp "losing" quality on the parent comp
                TimeRemapper Level 4

                I see the jaggies in the render, but I agree with Rick in that it would seem to possibly be an OpenGL issue. You're not rendering using OpenGL, are you?

                 

                Also, why not use PNG with an alpha? Or, have you tried using a different type of source file? Perhaps a .psd, a .tif (32 bit), a .tga (32 bit), etc... to see if that can eliminate the issue? If your comping your text on a black rectangle and compositing over a black background, unless you want some advantages of a rectangular-bound text graphic, then it might be generally better practice to use the text itself. Indeed, you could just use a text layer (3D) in After Effects if it suits the purposes of your work.

                1 person found this helpful
                • 5. Re: Precomp "losing" quality on the parent comp
                  Eliminateur Level 1

                  i've disabled opengl in view and render, you can see the jaggies in the rendered frame, below the textbox.

                  that textbox was supplied to me by the graphic artist in that format, it would be a PITA to recreate it in 3D text in AE(and i don't think it would be doable with a 100% match), the origin file has no alpha in it.

                  i could see if the artist can send me the vector master file(probably done in coreldraw) and import that instead

                  • 6. Re: Precomp "losing" quality on the parent comp
                    Rick Gerard Adobe Community Professional & MVP

                    I see the jaggies now on the bottom of the rendered frame. Couldn't see them on my iPhone. These are from the alpha channel around the edge of the png because it was either not set up correctly in the original artwork or the alpha is misinterpreted.

                     

                    You should be able to fix the problem with a mask in the pre-comp. You should also be able to fix the problem by changing the interpretation of the alpha channel in the png from premultiplied to straight or vice versa. Another option would be to open up the png in Photoshop and crop it by about a pixel then save it without an alpha.

                     

                    Screen Shot 2011-11-17 at 5.03.04 AM.png

                    • 7. Re: Precomp "losing" quality on the parent comp
                      RenéHuwaë

                      I've got the same problem. I thought I made a topic about this but I could't find it anymore.

                       

                      Anyway, I've got 2 comps, the first one is 8380x4714, and the second one is 1920x1080. The "zoom level"/magnification ratio popup matches the resolution (50% - half). I used the large comp in the smaller and animated the position, but it seems to be losing details.

                       

                      • Open GL is turned of
                      • The DOF in the camera in the 2nd comp is turned off.
                      • Motionblur is turned off in the 2nd comp.

                       

                      http://i1106.photobucket.com/albums/h379/Huwaetje/Random/Schermafbeelding2011-11-19om192606.png