5 Replies Latest reply on May 28, 2015 7:21 AM by Sunsneezer

    Auto resolution not adapting to zoom level

    mombasaman Level 1

      As the title states, the resolution does not adapt to the zoom level dispite having Auto selected.

       

      I also checked in the advanced composition options and preserve resolution when nested is selected.

       

      This issue happens in every comp and different project files.

       

      I'm running CS5 on Mac OS X 10.6.


      Any help would be greatly appreciated.

        • 1. Re: Auto resolution not adapting to zoom level
          Dave LaRonde Level 6

          Auto Resolution doesn't do what you apparently think it does.  Here's a quote taken from AE's Online Help about Auto Resolution:

           

          "Adapts the resolution of the view in the Composition panel to render only the pixels necessary to preview the composition at the current zoom level. For example, if the view is zoomed out to 25%, then the resolution automatically adapts to a value of 1/4—shown as (Quarter)—as if you had manually chosen Quarter. If a panel contains multiple views, the resolution adapts to the view with the highest zoom level. This setting gives the best image quality while also avoiding rendering pixels unnecessary for the current zoom level."

           

          Thus, if you look at your AE comp at something like 800%, you will see the pixels.  You're simply looking at the comp as you would with a magnifying glass.

           

           

          If you are scaling up a layer beyond 100% or if you're  animating a camera to see only a very small section of a layer, AE will not automatically add resolution to the layer to make it nice and sharp.  It can't.  The only exception is when you use text layers, or use vector graphics with the Continuously Rasterize switch turned on.

          • 2. Re: Auto resolution not adapting to zoom level
            mombasaman Level 1

            Hi Dave,

             

            Thank you for the response.

             

            Perhaps I might've worded my issue wrongly. That quote about Auto

            Resolution is exactly what I am talking about.

             

            I would set my resolution to auto and, previously, I would hit the shortcut

            keys to zoom in and out, and the resolution would change automatically.

            Typically I'd go down to 50% and the resolution would go down to half, all

            at the press of a button. This was very helpful when my comps were getting

            render heavy at full resolution - which is pretty much all the time.

             

            Recently I've been having this problem where changing the zoom level does

            not affect the resolution at all, despite being selected on Auto. I've done

            some searching and one of the fixes is to have Preserve Resolution when

            Nested unchecked in the Advanced composition options. Unfortunately it is

            unchecked and I am still having the same problem.

             

            Thanks again.

            • 3. Re: Auto resolution not adapting to zoom level
              Dave LaRonde Level 6

              This sounds like it could be a problem with AE Preferences.  Have you tried trashing the preferences file?

               

              You can also use Ctrl-Alt-Shift (Win) or Cmd-Opt-Shift (Mac) as you start AE to restore default preferences, which sounds a little less destructive.

              • 4. Re: Auto resolution not adapting to zoom level
                Todd_Kopriva Level 8

                As Dave suggests, start by resetting your preferences and see if that gets things back to the behavior that you were getting before.

                • 5. Re: Auto resolution not adapting to zoom level
                  Sunsneezer

                  I had the same behavior. Deleting the preferences wouldn't help. There are two different behaviors that cause that:

                  1. The Auto setting is ignored for compositions for which the Advanced composition setting Preserve Resolution When Nested is selected.
                  2. If a panel contains multiple views, the resolution adapts to the view with the highest zoom level

                  (from the help)

                   

                  Since you ruled out 1, I would guess 2.
                  By the way, I discovered that the help text is a bit too specific about point 2. I didn`t have multiple views but two comp panels open. Closing the other one restored the auto resolution behavior.