4 Replies Latest reply on Aug 18, 2006 10:20 AM by DynamicGuyNC

    CFGRID not working

    DynamicGuyNC
      I have a server running CFMX 7 and CentOS release 4.3 (Final). It is a brand new installation of CF on this server, and I'm having problems getting CFGRID to run.

      The error I'm getting in the browser is:
      load: class coldfusion.applets.CFGridApplet.class not found.
      java.lang.ClassNotFoundException: coldfusion.applets.CFGridApplet.class
      at sun.applet.AppletClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at sun.applet.AppletClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at sun.applet.AppletClassLoader.loadCode(Unknown Source)
      at sun.applet.AppletPanel.createApplet(Unknown Source)
      at sun.plugin.AppletViewer.createApplet(Unknown Source)
      at sun.applet.AppletPanel.runLoader(Unknown Source)
      at sun.applet.AppletPanel.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: open HTTP connection failed.
      at sun.applet.AppletClassLoader.getBytes(Unknown Source)
      at sun.applet.AppletClassLoader.access$100(Unknown Source)
      at sun.applet.AppletClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      ... 10 more

      I've seen this error posted, but no responses. Could someone please help me with this issue and resolve it for everyone else who seems to be having this problem?

      Thanks!
      David
        • 1. Re: CFGRID not working
          <newbie /> Level 1

          I'm not certain but it looks like the java code (.class, .jar, etc) may not be
          available from the URL?

          I think the cfgrid component, cfform stuff, etc. requires that your CFIDE directory
          is publicly available and that it can be accessed via URL.

          ex.
          http://dynamed/CFIDE/[insert directory it's trying to access here]

          Good luck!


          • 2. Re: CFGRID not working
            DynamicGuyNC Level 1
            I looked at the CF Admin and these are the mappings that are currently setup:

            /CFIDE -> /var/www/html/CFIDE (this one cannot be updated or deleted)
            /gateway -> /opt/coldfusionmx7/gateway/cfc

            Is there another mapping that should be set?
            I tried adding one for '/' to the same location as CFIDE but it didn't make a difference.
            I also tried adding one with https://secure.myhomecarebiz.com (the default site for the server) and it told me to enter a valid name for the Path.

            Any suggestions?
            Thanks!
            David
            • 3. Re: CFGRID not working
              <newbie /> Level 1

              I'm not sure this is a config issue in CF Admin?

              I think what determines whether files (.css, .js, .class, .jar, etc) can be accessed
              via URL is the Web Server?

              I'm new to CF and I'm not sure how it all works but it seems to me that CF is out
              of it when it comes to retrieving non-cfml files?

              Meaning, if a user's browser/applet/webpage is trying to retrieve a .jar or .class from the Web Server, the CF engine does not even know that the request for the .jar or .class or .js or .css has been made.

              The Web Server should simply return the requested resource from disk without
              further processing or handing it off to some other processing engine.

              So if you leave CF out of it, perhaps the thing to investigate is why the Web
              Server does not appear to be able to serve-up files under the CFIDE/... directory?

              Anyway, sorry I have not been any help.

              Good luck!
              • 4. Re: CFGRID not working
                DynamicGuyNC Level 1
                Unfortunately, I'm not very knowledgeable in that area either.

                The only thing I can think of is that it may have something to do with setting up CF in a shared type of environment. For both of my servers, there are multiple websites using the CF server.

                I dunno. Thanks for trying.
                David