7 Replies Latest reply on Feb 26, 2012 10:35 AM by TheStuMystro7

    Importing .mts files not nested in original camera folder structure

    vincejosedotcom

      The short version:

      Is there any way to import .mts files already copied to a hard drive, without keeping the camera's folder structure intact, into Premiere Pro CS5.5?

       

      The long version:

      I recently purchased an iMac. For years I edited video on Windows using Sony Vegas and Vegas Home Studio. My camera, the Panasonic Lumix TS2, shoots AVCHD video. Vegas has no problem importing and editing AVCHD .mts files from a camera or a hard drive so it wasn't until I attempted to edit some video in Premiere Pro, recieved the "unsupported compressions type" error message and did some searching that I realized folder structure is so critial to working with AVCHD. From what I can tell, the files have to be in the PRIVATE>AVCHD>BDMV>STREAM>xxxxxxx.mts confirguration to be imported via the media browser.

       

      Here is my situation, I have hundreds of .mts files in separate folders, bundled together with photos from the same day or event. I'm on an iMac i7, using an activated version of Premiere Pro CS5.5 from the Master Collection. Is there any way I can import and edit these files natively? And in the future, is there any way around transferring the entire folder structure everytime I want to copy the video files to my hard drive? I use Bridge to import photos and it will just pull the video files off the card and plop them in the same folder. Having to transfer the videos separately seems like a silly work around in our modern age. Thanks for any help you can provide.

        • 1. Re: Importing .mts files not nested in original camera folder structure
          Colin Brougham Level 6

          AVCHD .MTS files should import just fine without the folder structure. You'll lose metadata, timecode, and spanning, but beyond that, the files themselves should work fine.

           

          Do you have the AVCHD sequence presets? It's possible that you've lost the ability to import the material; Pr has a bad habit (particularly on Mac) of getting format-amnesia when you update. Did you recently update to 5.5.2?

          • 2. Re: Importing .mts files not nested in original camera folder structure
            vincejosedotcom Level 1

            Thanks for the response. Yeah I just attempted to take new video and import it directly from the sd card and it gave me the same error so all my presumptions about the issue are wrong.

             

            I got the error message both before and after the update. It has never worked for me. Sorry I'm new to this, I don't believe I havbe the AVCHD sequence presets. I'm geussing it should be an option when you make a new sequence. I know there was some issue with the trial version and AVCHD a while back but I understand the trial has all capabilities now.

             

            This gives me another way of attacking this. I'm going to try de- and reactivating per the suggestion in another post (which you've also contributed to).

            • 3. Re: Importing .mts files not nested in original camera folder structure
              TheUltimateFX

              Yo! I used to have this problem for about 1 year!! And fixed it about half a year ago and I have never been as happy when I fixed it!

               

              Be sure that your sequence settings are set to the right settings: When you create a new sequence you should be promped with a window asking what settings you want. Open the "AVCHD" folder and there should be 3 folders; 1080p, 1080i, 720p. Pick the one that you filmed at, I film at 1080p, so I open that folder and then you pick the right setting to what you filmed your scene. I film at 24 fps so i pick AVCHD 1080p24 (non-anamorphic). Now there should be a new sequence with the right settings (don't use the same settings as I do unless you have filmed at the same frame rate and that it was filmed at 1080p or 1080i, there is a big difference between "p" and "i"). If you go in to the window in the bottom left corner there should be a tab on that box that says "Media Browser". Click it and the directory to your computer should be shown. If you have your SD card connected there should be something called SD card (or if you have renamed it then it is obvious what you should select). After selecting it there should be a folder called AVCHD and you open it up. This is where it gets tricky... because I don't know what camera you use and don't have any experience with your camera then you will have to go through all the folders that are within the AVCHD folder. They are not so many but in the folder where all the clips are hidden they should be called 00626.mts for example. Then you just select the clips you want to import and import them. This process can also be done by opening Finder (mac) or on PC just open up the same way and select the clips you want and drag them i to your project window

               

              Then if you drag a clip in to the sequence, this is were you see if you did all the steps right (with the sequence settings) then the light above the clip should be yellow, meaning that the playback engine recognizes the format and can play it back without any compression Therefor giving you much better quality videos!

               

              Hope this helps, I know the pain you are going through, don't want it to happen to anyone else

              • 4. Re: Importing .mts files not nested in original camera folder structure
                TheStuMystro7 Level 1

                Hi there,

                 

                I am having the same problem importing .mts files into APP 5.0.4 so was very interested to read your response.  But unfortunately when I go to create a new sequence I only have the options of PAL, NTSC, and DVCPROHD folders.  There is no AVCHD folder there.  Obviously there is something missing, any idea what I need to do to get this sorted?  Thanks.  Stu

                • 6. Re: Importing .mts files not nested in original camera folder structure
                  vincejosedotcom Level 1

                  Jim Simon has posted the appropriate link. Seems like a recent update reverted our copy to trial mode or made some other change that blew away many of the available presets. This has been an ongoing issue with Premiere (for some users) CS%, CS4 and maybe CS3. I haven't yet tried it this go around but uninstalling, cleaning and installing plus activating worked for me in November.

                  • 7. Re: Importing .mts files not nested in original camera folder structure
                    TheStuMystro7 Level 1

                    Hi there, I have tried to do as suggested in this post, but after the first clean I can still see a few Adobe 5.0 App's in my App's folder.  After rebooting twice I still can't get Adobe Cleaner Tool to see them in order to do another clean. Just comes up with a blank screen with nothing to select.  I am not convinced this is going to work for me anyway as I was having problems importing .mts files prior to updating my copy of 5.0.0 to 5.0.4.  So it wasn't working to begin with.  I don't think cleaning and reinstalling is going to help even if it did work.  Any other ideas?  Anyone?