0 Replies Latest reply on Nov 29, 2011 7:32 AM by Stephcook22

    Trouble migrating from SDK 4.1.0 to 4.5.1 with auto updater

    Stephcook22

      I have just upgraded to Flash Builder 4.5 from 4 but am now having problems with the auto updater.

      I am getting this error: There was an error downloading the update. Error# 16824

       

      I have followed these instructions: http://www.adobe.com/devnet/air/articles/air_update_framework.html#articlecontentAdobe_num beredheader_4

       

      But have yet to succeed.

       

      Currently my app contains the new update swcs as instructed in the above and points to the following xml file:

       

      <?xml version="1.0" encoding="utf-8"?>

      <update xmlns="http://ns.adobe.com/air/framework/update/description/1.0">

                <version>Beta 1.0.2</version>

                <force>true</force>

          <url>http://domain.com/Beta_1_0_2.air</url>

          <description><![CDATA[

                Change over to new update procedure

          ]]></description>

      </update>

       

      but i am still getting that error.

       

      I have tried swapping the framework description and checking through all my code but still nothing.

       

      Any help would be greatly appreciated as I need to know I can push the new version out as an update.