0 Replies Latest reply: Nov 30, 2011 9:44 AM by dq212 RSS

    Multiple Errors when trying to downgrade from 4.5.1 to 4.1

    dq212 Community Member



      I built a project in Flash Builder using the 4.5.1 SDK. My client also needs the project in 4.1 in order to play in Flash Player 10.1.

      This change will not compile.


      I am using robotLegs 1.5.2 and OSMF


      I tried simply changing the SDK in the compiler settings, but to no avail.


      I have tried swapping the the Version of OSMF.swc in my local libs folder and I get varying results.


      With OSMF 1.5 I get errors relating to:





      With OSMF 1.0 I get:


      VerifyError: Error #1014: Class mx.styles::AdvancedStyleClient could not be found.



      Others erros I have gotten throughout my debugging have been Verify Errors relating to:






      Anyone familiar with these types of errors speific to FlashPlayer 10.1?


      Thank you.