4 Replies Latest reply on Feb 3, 2012 12:53 PM by carlosluisquesada2

    Error compiling for IOS "map failed"

    mr1966_de

      Since i have installed Flash Builder 4.6 I allways get an error when I compile for Device "Map Failed".

      Compiling for Desktop works fine. When I used Flash Builder 4.5.1 I had sometimes the same problem,

      but sometimes compiling worked.

      here is the logfile:

       

      !ENTRY com.adobe.flexbuilder.project 4 43 2011-12-07 12:16:06.832

      !MESSAGE Map failed

      !STACK 0

      java.lang.Exception

          at com.adobe.flexbuilder.project.internal.FlexProjectCore.createErrorStatus(FlexProjectCore. java:1019)

          at com.adobe.flexbuilder.util.logging.GlobalLogImpl.log(GlobalLogImpl.java:66)

          at com.adobe.flexbuilder.util.logging.GlobalLog.log(GlobalLog.java:52)

          at com.adobe.flexide.multiplatform.ios.packaging.IPAPackager.create(IPAPackager.java:276)

          at com.adobe.flexide.multiplatform.ios.launching.IOSOnDeviceLaunchHandler.doPackage(IOSOnDev iceLaunchHandler.java:314)

          at com.adobe.flexide.multiplatform.ios.launching.IOSOnDeviceLaunchHandler.launch(IOSOnDevice LaunchHandler.java:185)

          at com.adobe.flexide.launching.multiplatform.MultiPlatformLaunchDelegate.launch(MultiPlatfor mLaunchDelegate.java:191)

          at com.adobe.flexide.launching.AbstractFlexLaunchDelegate.launch(AbstractFlexLaunchDelegate. java:244)

          at com.adobe.flexide.launching.AbstractFlexLaunchDelegate.launch(AbstractFlexLaunchDelegate. java:134)

          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:854)

          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:703)

          at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:928)

          at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1132)

          at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

       

      !ENTRY com.adobe.flexbuilder.project 4 43 2011-12-07 12:16:07.520

      !MESSAGE Fehler beim Verpacken der Anwendung:

       

      Map failed

       

      What can I do ?

        • 1. Re: Error compiling for IOS "map failed"
          tksl_rbt

          I am getting a similar error when exporting a release build for ios.

           

          It seems to be caused by the number of assets I include in the project. If I remove all of the video assets from the package it builds a working release. When the video assets are included, it fails to export the release build with the error "map failed".

           

          So it seems to be the number of assets included or the total size of the included assets that causes the error for me. But I can't find a way around it so can't currently export a release build with all the required assets.

           

          I'm starting to wonder wether I'm going to have to write some kind of "updater" to download all the required assts to the iOS device when the app is first run, which isn't ideal.

          • 2. Re: Error compiling for IOS "map failed"
            mr1966_de Level 1

            I found a workaround.

            Using a Computer with faster CPU, more RAM and Windows7 (instead XP) it worked for me.

            • 3. Re: Error compiling for IOS "map failed"
              tksl_rbt Level 1

              Thanks for providing an update, very useful.

               

              We're building on a reasonably powerful machine (Windows 7, 4gb Ram, i5 2500k processor) but it does have only 4-5Gb of hard disk space free on the drive Flash Builder is installed on. As it's attempting to build a .ipa file that will be 850mb or so, I wonder if that could be causing the problem.

               

              As a test, I installed the Flash Builder trial on a brand new iMac we have here. Think that should have a similar amount of RAM and processor, but had 480gb of free hard disk space. That seems to have compiled without the error.

               

              Anyway, good to have some options! Thanks again.

              • 4. Re: Error compiling for IOS "map failed"
                carlosluisquesada2

                I was getting the same error. And found this post. I now it's old, but for the record this is how I solved it in my case:

                 

                When you Export Release Build, Flash Builder creates a folder suffixed "-temp", for example, "bin-release-temp". I noticed after one of the builds failed this folder was not deleted. I fixed the bug, but started getting the "Map failed" error.

                 

                I manually deleted "bin-release-temp" from my project folder, and exported successfully.