14 Replies Latest reply on Jan 3, 2012 9:30 AM by amagg49

    Smartmix problems

    DeVosLenny

      Hi,

       

      I have run into an issue with using smartmix in my projects.

       

      Sometimes an error message appears. I have to sort of literally translate it from my Dutch program version, but it says something like "can't execute smartmix. missing audio in foreground or background track."

       

      When this happens, nothing seems to help. I have closed down the program completely and restarted it but I get the same error. Removing the audio from the timeline and putting it back doesn't help either.

       

      A Google search didn't come up with anything useful.

       

      Does anyone know how to fix this?

       

      Thanks,

       

      Lenny

        • 1. Re: Smartmix problems
          the_wine_snob Level 9

          Lenny,

           

          Welcome to the forum.

           

          Which version of PrE are you using? I would assume PrE 10, but is it the 32-bit, or 64-bit, if it IS PrE 10?

           

          What are the full specs. of the Audio Stream, to which you are attempting to apply SmartMix?

           

          Good luck,

           

          Hunt

          • 2. Re: Smartmix problems
            DeVosLenny Level 1

            Hi and thanks for your message.

             

            I am using Premiere Elements 9 on a Windows 7 computer.

             

            I am not exactly sure what you mean with "full specs" but the video

            files with sound are .avi and the additional soundtrack song is .mp3.

             

            Lenny

             

            Op 8/12/2011 20:58, Bill Hunt schreef:

            >

                  Re: Smartmix problems

             

            created by Bill Hunt <http://forums.adobe.com/people/the_wine_snob> in

            /Premiere Elements/ - View the full discussion

            <http://forums.adobe.com/message/4072234#4072234>

             

            • 3. Re: Smartmix problems
              the_wine_snob Level 9

              Lenny,

               

              Thank you for that info. Unfortunately, with regards to the Source Files, we need a lot more. "AVI" is almost meaningless, as it is but a wrapper, a container, if you will. See this ARTICLE for much more detail, and also tips on how to peek inside the wrapper.

               

              Good luck, and please let us know what G-Sport, or MediaInfo have to say about the file.

               

              Hunt

              • 4. Re: Smartmix problems
                DeVosLenny Level 1

                Hi,

                 

                I didn't realise possible codecs could have an influence.

                 

                However, I used Gspot and the audio files appear to be regular PCM Audio

                ... as opposed to mp3 which I said before.

                 

                I took screenshots of the full specs. You can check them here:

                http://dl.dropbox.com/u/22815213/Screenshots.zip (two image files in the

                zip)

                 

                The odd thing is that the problem doesn't occur on every computer. I

                just reran the case on another PC (also Windows 7 with Premiere Elements

                9) and there are no problems whatsoever.

                 

                Thanks,

                 

                Lenny

                 

                Op 9/12/2011 1:27, Bill Hunt schreef:

                >

                      Re: Smartmix problems

                 

                created by Bill Hunt <http://forums.adobe.com/people/the_wine_snob> in

                /Premiere Elements/ - View the full discussion

                <http://forums.adobe.com/message/4072737#4072737>

                 

                • 5. Re: Smartmix problems
                  the_wine_snob Level 9

                  Lenny,

                   

                  Thank you for the G-Spot screen shots. That shows that you have two different Audio types, but they both should work fine in PrE. To step back a bit, PrE will Conform all Imported Audio to 48KHz 32-bit floating point for editing. The Conforming takes place with all Audio, and creates the CFA file (the actual Conformed Audio for editing) and then the PEK file, which is the Waveform Display. This ARTICLE goes into much more detail.

                   

                  Both the 48KHz 16-bit (DVD-Video spec.), and the 44.1 KHz 16-bit (CD Audo spec.), should Conform flawlessly to the 48KHz 32-bit floating point (CFA), so I do not see a problem there.

                   

                  As it's actually the CFA file (does not play outside of PrE, or PrPro), that is edited, I do not know what would cause SmartMix to mess up - should be easy, but for some reason, it is not.

                   

                  Now, I am not versed on exactly what SmartMix does, or how it does it. I am sure that Steve, Neale, ATR or others will know, and may have some ideas on why things are not working for you. The posting of that info will be useful for them to help out, so nothing has been done unnecessarily.

                   

                  Wish that I had more, but you have helped narrow things down greatly.

                   

                  Good luck,

                   

                  Hunt

                  • 6. Re: Smartmix problems
                    DeVosLenny Level 1

                    Hi,

                     

                    In any case thanks for your input. If anyone else has any ideas or has

                    run into this issue, suggestions are welcome.

                     

                    I do realise that it is better to manually put in keyframes, but I'm

                    trying to teach some students to work with Premiere Elements and for

                    them, at this point in their learning curve, things still have to be

                    kept rather basic. I will however teach them later how to "ditch"

                    smartmix and work on the volume manually.

                     

                    Lenny

                     

                    Op 9/12/2011 16:42, Bill Hunt schreef:

                    >

                          Re: Smartmix problems

                     

                    created by Bill Hunt <http://forums.adobe.com/people/the_wine_snob> in

                    /Premiere Elements/ - View the full discussion

                    <http://forums.adobe.com/message/4073875#4073875>

                     

                    • 7. Re: Smartmix problems
                      the_wine_snob Level 9

                      Lenny,

                       

                      Because of my lack of experience with, and lack of knowledge of, SmartMix, I did some poking around, and found this tutorial on Adobe TV. Not sure if you have seen it. I watched, and tried to apply what Jan shows, to what I remembered of your post. I did not see anything that stuck out, but maybe you will.

                       

                      I do agree about starting a student off with some easy basics (kind of to "draw them in") and then introduce more involved, and often abstract conceptes, later on. Steve Grisetti, our tireless MOD and noted author, does this well with his Basic Training Series, then his Learning Series, and finally his Tips & Tricks Series.

                       

                      I would also expect that he'll drop by this thread, and can see what I am overlooking.

                       

                      Good luck, and happy teaching,

                       

                      Hunt

                      • 8. Re: Smartmix problems
                        DeVosLenny Level 1

                        Hi,

                         

                        I may ask my students to remove the folders that contain the conformed

                        audio data, thus forcing Premiere to re-conform at the next project

                        load. Who knows, it might help!

                         

                        The materials that Adobe offers for learning their programs are great.

                        However, they are usually not available in Dutch. I have no problem

                        whatsoever understanding the English materials, but most of most

                        students barely speak any English or none at all. It is hard to find

                        books or tutorials. I tend to make all my materials myself.

                         

                        Lenny

                         

                        Op 9/12/2011 17:42, Bill Hunt schreef:

                        >

                              Re: Smartmix problems

                         

                        created by Bill Hunt <http://forums.adobe.com/people/the_wine_snob> in

                        /Premiere Elements/ - View the full discussion

                        <http://forums.adobe.com/message/4074035#4074035>

                         

                        • 9. Re: Smartmix problems
                          amagg49

                          Hi,

                          sorry for my English! I have the same problem. The Smartmix open a message windows with:
                          "Impossible to exec the advanced Mix. The tracks on foreground or background do not

                          contain audio", of course in italian with Windows 7, 64bit, Premiere Elements 10.0.

                          I can hear both tracks and see the audio on a mixer level on both tracks.

                          My camera is a Panasonic HDC TM-700, recording at 50p,stareo, the soundtrack is a folk music

                          mp3. I also try with wav soundtrack unsuccessfully.

                          Thanks for any help,

                          Angelo

                          • 10. Re: Smartmix problems
                            Steve Grisetti Adobe Community Professional

                            As we often warn on this forum, 50p and 60p video can cause some strange things to happen in this program.

                             

                            Try mixing 50i or 60i video with WAV files instead of MP3s and see if that makes a difference. Although the program should be able to work with MP3s, it often has trouble with them. (You can convert MP3s to WAVs with the free download Audacity.)

                            • 11. Re: Smartmix problems
                              the_wine_snob Level 9

                              As Steve says, some MP3's work fine, but others do not. This ARTICLE goes into a bit more detail.

                               

                              Out of habit, my workflow is to always convert MP3's (except for tiny SFX files) to PCM/WAV @ 48KHz 16-bit, and that has always worked for me.

                               

                              Good luck,

                               

                              Hunt

                              • 12. Re: Smartmix problems
                                amagg49 Level 1

                                Thanks a lot Steve for your fast answer,

                                Of course I did some test before my help request submission,

                                just to be sure that was not my mistake or some stupid error.

                                The first test was exactly your suggestion, conversion of mp3 file to wav (Microsoft

                                16bit PCM) using Audacity.

                                Problem still there with the same error message.

                                This mornig I did two new test.

                                I read carefully the article of Bill Hurt and repeat carefully the wav conversion

                                using audacity. No solution to the problem, same error message.

                                 

                                The second test was decisive to answer the problem.

                                I just resume my old pc running XP-SP3 and Premiere Elements 8.0.

                                The smartmix applied to the same Premiere input file work perfectly well.

                                The file has just one clip of 10s of recorded movie (with audio) and one mp3 song as

                                soundtrack.

                                 

                                In Italy we say: the test "cut the head of the bull" ie the answer is clear and with no doubts.

                                It is a bug of PrE 10.0, at least in the version for Windows 7.0 64bits.

                                 

                                I don't know how submit an error report to Adobe or ask back my money for the version 10.0

                                and work with my working version 8.0.

                                Any suggestion?

                                 

                                Thanks a lot, Angelo

                                 

                                PS I am running PrE since long time, from the version 1.0 that was really full of bugs!

                                • 13. Re: Smartmix problems
                                  the_wine_snob Level 9

                                  Thank you for running the tests, and then taking time to publish your findings. This tells you how to file a Bug Report.

                                   

                                  Good luck,

                                   

                                  Hunt

                                  • 14. Re: Smartmix problems
                                    amagg49 Level 1

                                    Thanks a lot Bill,

                                     

                                    I read your report and I follow the adderess to submit a bug report.

                                    Unfortunately there is no possibility to send a bug report for Premiere

                                    Elements. There i a selection for feature Request and bug Report for

                                    many Adobe products but only Feature Requet for Premiere Elements

                                     

                                    Regards,  Angelo