1 Reply Latest reply on Jan 27, 2013 11:55 PM by Webdaddy

    CF Search/Replace bug?

    Abram Adams Level 1

      First off, I run CFB2 as a plugin to FB 4.5 on Win7 64bit.  All was working properly until I installed the FB 4.6 release.  Now, my "ColdFusion Search" no longer performs a replace.  When I hit CTL+F I get the ColdFusion Search dialog like normal, type in my search criteria and hit Find it finds a match.  If I hit Find All it finds all matches.  So far so good.  Now if I hit Replace All it does the search, but then I never get the "ColdFusion Replace Dialog".  It just opens up my search view and shows my matches.  Even if I use a single Replace it does not replace.

       

      I've uninstalled FB 4.6 and CFB2 completely and re-installed and have the same problem.  When I uninstall FB 4.6 and CFB2 then re-install with FB 4.5 and CFB2 the problem goes away.

       

      Note: I have tried with and without the CFB2 hotfix 1 with same results.

       

      So, am I the only one or should I log a bug report?  I really want to use the new FB 4.6 features for our Air3 development, but can't sacrifice something as critical as a search/replace function on my CF stuff, and two standalone installs would defeat the purpose of having the IDE built on Eclipse.

        • 1. Re: CF Search/Replace bug?
          Webdaddy Level 1

          I, too, am more than a little annoyed at the problematic "Find' function in files opened via RDS. The only way to get it to actually find anything is to do a replace on the same term!  When I try to "Find All" I get a "No open file." message.  The hotfix has done nothing to fix this problem.

           

          HELP!