1 Reply Latest reply: Dec 16, 2011 12:23 AM by agile116@hotmail.com RSS

    Flex 4.5 upgrade issue

    agile116@hotmail.com Community Member

      Hi All,


      I have come into the following RTE when I upgrade my application from 3.5 to 4.5. Any clue about this issue?

      ArgumentError: Error #2004: One of the parameters is invalid.

          at flash.display::Graphics/drawRect()

          at mx.controls::VRule/updateDisplayList()[E:\dev\4.5.1\frameworks\projects\mx\src\mx\control s\VRule.as:256]

          at mx.core::UIComponent/validateDisplayList()[E:\dev\4.5.1\frameworks\projects\framework\src \mx\core\UIComponent.as:8989]

          at mx.managers::LayoutManager/validateDisplayList()[E:\dev\4.5.1\frameworks\projects\framewo rk\src\mx\managers\LayoutManager.as:736]

          at mx.managers::LayoutManager/doPhasedInstantiation()[E:\dev\4.5.1\frameworks\projects\frame work\src\mx\managers\LayoutManager.as:801]

          at mx.managers::LayoutManager/doPhasedInstantiationCallback()[E:\dev\4.5.1\frameworks\projec ts\framework\src\mx\managers\LayoutManager.as:1180]


      I debugged and found that the unscaledHeight in updateDisplayList of VRule is NaN, anyone knows the reason? Thanks.

        • 1. Re: Flex 4.5 upgrade issue
          agile116@hotmail.com Community Member

          I just found that set the percentHeight is unable to set unscaleHeight correctly. The following is the old implementation, if I change percentHeight=80 to height=25, the error is gone. But why is it happenned? I can't just set the height to 25 here. Anyone can help?


          public class VRuleImpl extends VRule{

          percentHeight = 80;