3 Replies Latest reply on Dec 16, 2011 3:41 PM by drkstr_1

    Can't import Flex project

    bonnie1b

      I wonder if someone can  help me with this.  I am using FlexBuilder 3.  I am unable to import my project from one laptop to another.  The old laptop had CF8 and the new has CF9 so I’m not sure if this is the problem. When I try to import an archive I exported from the CF8 laptop, I get the prompt to update the path variables.  It accepts the path to ColdFusion9 but will not accept the web root.  I have tried C:\inetpub\wwwroot but it gives error message saying ‘the selected web root folder does not exist’.  I also tried C:\inetpub and C:\ColdFusion9\wwwroot. 

       

      I’m stumped at this point and desperate to get this imported.  I have been having a nightmare trying to migrate this application from CF8, Windows Server 2003, IIS 6 to CF9, Windows Server 2008, IIS7.5.  We are also using SSL so from what I’ve read I will have to recompile all these swfs with some changed XML config files.  But of course, the first step is getting the app into FlexBuilder.

        • 1. Re: Can't import Flex project
          drkstr_1 Level 4

          What folder are you using as the webroot? If it says that folder doesn't exist (C:\inetpub\wwwroot), it sounds like you need to set up your IIS first.

          • 2. Re: Can't import Flex project
            bonnie1b Level 1

            Thanks for the reply drkstr_1. I've got IIS working (I think) since the CF app comes up fine and I can surf about.  It's the flex grids I have that won't work. I get: "Destination 'ColdFusion' not accessible over channel 'my-cfamf-secure'".  Actually, the flex grids DO work with http, but they don't work using https.  I had found information to add secure channel info to the remoting-config.xml and services-config.xml files.  Once those channels are added, I need to recompile the swfs.  But first is to get the project into this new laptop FlexBuilder.  I'm using C:\inetpub\wwwroot for my websites.  And here is what I'm trying to follow for the recompiling and reconfiguring: http://blog.crankybit.com/flex-remoting-over-ssl/

            • 3. Re: Can't import Flex project
              drkstr_1 Level 4

              Is the problem that the app won't import at all because of the missing directory? If so, just create it temporarily and update the wwwroot in the project settings once it's imported.