3 Replies Latest reply on Dec 19, 2011 9:39 AM by jaymcdonald

    PSD clipping layer

    jaymcdonald Level 1

      I am just getting started with After Effects, and in a recent experiment, I brought in a simple PSD file that happens to use a clipping layer to crop another layer. The bottom layer is the box used for clipping, and the top layer is the photo that was being clipped. I imported to AE as a composition, and now I can not seem to get rid of the clipping layer without the photo layer disappearing (it's still there, but doesn't show). What is going on, and how can I sort this out?

       

      Here is my test file: http://download.hexatrope.com/brandingImage.zip

        • 1. Re: PSD clipping layer
          Mylenium Most Valuable Participant

          You have the preserve transparency switch enabled in teh top layer (the little checkerborard thing). Turning it off gives the behavior you'd expect.

           

          Mylenium

          • 2. Re: PSD clipping layer
            jaymcdonald Level 1

            Fantastic! Is there a way to apply the cropping permanently?

            • 3. Re: PSD clipping layer
              Mylenium Most Valuable Participant

              I'm not sure what you mean by "cropping". AE works non-destructively and the only way to make something you do in the program permanent is to render the output to a new file. If you just want to get rid of the excess empty areas, adjust your composition size in the comp settings. Alternately, enable the region of interest, match the frame to your image, then do a Composition --> Crop to ROI.

               

              Mylenium

              • 4. Re: PSD clipping layer
                jaymcdonald Level 1

                Ah, OK. That's a key bit of knowledge. "Everything is non-destructive". That means if the Photoshop comps masked off large images into little images - I have to actually crop them to size (remove everything that is masked) in Photoshop. Otherwise, I will have all kinds of extra, unused junk that is present, but not visible.

                 

                Thanks.