1 Reply Latest reply: Dec 19, 2011 6:58 AM by Chuck Myers (Adobe) RSS

    XML data empty after reader extending form

    Kristian Wright Community Member



      I'm having a strange problem with Workspace and Process Management after reader extending a form.  The form is bound to a schema, and on an unextended form, the data passes from task to task with all entered information in tact. But as soon as I reader extend the form and deploy it into my application, after the initial submission all I have is a set of empty data:


      <xdp:xdp xmlns:xdp="http://ns.adobe.com/xdp/">

          <xfa:datasets xmlns:xfa="http://www.xfa.org/schema/xfa-data/1.0/">







      In the unextended version, ServiceRequestForm is full of data as passes from task to task.


      My workspace start point Action Profile uses '/Process Management (system)/1.0/Submit PDF Form.process' to submit the form.  On the unextended form the Submit PDF Form process runs, but after extending the form it never runs (confirmed by the fact that it does not record the process on an extended form).  Unfortunately I cannot extend the form in the Action Profile itself.


      Does anyone know why this might be happening, and what I can do to fix it?




        • 1. Re: XML data empty after reader extending form
          Chuck Myers (Adobe) Community Member

          I've never heard of anything like this before.  I'd suggest that you go down two paths.


          Self-diagnosis: Try a few things with the form.  Your email doesn't make clear whether you're using Acrobat with the reader-extended form or you've moved over to Reader.  I'd try it both ways. Also, when you reader-extend, just give it every right, like import/export form data.


          When you give up: And then, if all this fails, I'd contact support, pointing them to this thread.


          Also, anyone reading this should note that this issue is also posted in Process Management and Workspace