1 Reply Latest reply on Dec 19, 2011 12:33 PM by Xircal

    need flash player 9 for mac os 10.5

    raclh

      i am unable to download flash 10, so it recommended that for my system, which is mac os 10.5.8 with safari 4.0.2 i need flash player 9....but when i download the zip files from the archives i can't open it. am i missing something here or is the link not working? if someone can get me a working link so i can download flash player 9 that would be great. i had to uninstall the existing flash player because it had a problem and shut down safari whenever i went to a site with that plug in.