4 Replies Latest reply on Apr 14, 2017 4:23 PM by DejaVuYou

    Disable Missing Fonts dialog box

    RonWise Level 1

      Hey all,

       

      I know this has been asked before but I can't get the search feature on this forum to work very well. I have got to figure out a way to kill this box. I'm using AppleScripts to import Word files into InDesign CS5.5 templates and that box pops up all the time a kills the script. The necessary fonts are active and FontAgent Pro auto activates the ones that are not. However, INDD loses its mind and thinks there are missing fonts. I'm seriously about ready to shoot myself in the face because I can't get any work done.

       

      One suggestion I've seen is to insert this line:

       

      app.scriptPreferences.userInteractionLevel = UserInteractionLevels.NEVER_INTERACT;

       

      Where? This doesn't look like AppleScript code to me and none of the posts I've read say where to put this. Please help!

       

      Thanks and Merry Christmas!

        • 1. Re: Disable Missing Fonts dialog box
          csm_phil Level 4

          Hi Ron,

           

          This below code is like never interact the dialog box using the apple script. 

           

          set user interaction level to never interact
          

           

           

          thx

          csm_phil

          • 2. Re: Disable Missing Fonts dialog box
            Green4ever Level 3

            This is a java scrpit code save it as .jsx file and run it from your scripts panel.

            to revert it use the below line.

            app.scriptPreferences.userInteractionLevel = UserInteractionLevels.INTERACT_WITH_ALL;

             

            Green4ever

            • 3. Re: Disable Missing Fonts dialog box
              RonWise Level 1

              @Phil: we've tried that but it doesn't seem to have any effect. I put it in right after the initial "tell application Adobe InDesign..." — is that correct or does it belong elsewhere? I also put a 4 second pause in the script right after the Word file imports to give me an opportunity to okay the dialog box but that doesn't help if it appears a minute or two into the script run.

               

              @Green: I'm going to give that a shot on Tuesday when I get back to the office.

               

              Thanks to you both!

              • 4. Re: Disable Missing Fonts dialog box
                DejaVuYou Level 1

                So this "missing font" dialog box is going to annoy everybody everytime and adobe chooses to never help it's customer work efficiently. I will never use fontkit so itvis a virus as far as I am concerned. It seems adobe is less concerned about user experience and more intent on shoving typekit by accident at least. Does adobe hate customers ?