0 Replies Latest reply on Dec 26, 2011 12:36 AM by gabbyrub

    mysql problems

    gabbyrub

      i created this form and on test operation INSERT works but in MXML whan i run the project it's not and also no response token mysql have no new records! 

      <?xml version="1.0" encoding="utf-8"?>

      <s:View xmlns:fx="http://ns.adobe.com/mxml/2009"

              xmlns:s="library://ns.adobe.com/flex/spark"

              xmlns:valueObjects="valueObjects.*"

              xmlns:dataservice2="services.dataservice2.*"

              actionBarVisible="false" title="">

          <fx:Script>

              <![CDATA[

                  protected function button_clickHandler(event:MouseEvent):void

                  {

                      var data2:Data = new Data();

                      data2.ID = parseInt(iDTextInput.text);

                      data2.info = parseInt(infoTextInput.text);

                     

                      createDataResult.token = dataService2.createData(data2);

                  }   

              ]]>

          </fx:Script>

          <fx:Declarations>

              <valueObjects:Data id="data"/>

              <dataservice2:DataService2 id="dataService2"/>

              <s:CallResponder id="createDataResult"/>

       

          </fx:Declarations>

          <s:Form defaultButton="{button}">

              <s:FormItem label="ID">

                  <s:TextInput id="iDTextInput" text="{data.ID}"/>

              </s:FormItem>

              <s:FormItem label="Info">

                  <s:TextInput id="infoTextInput" text="{data.info}"/>

              </s:FormItem>

              <s:Button id="button" label="CreateData" click="button_clickHandler(event)"/>

          </s:Form>

          <s:Form>

              <s:FormItem label="CreateData">

                  <s:TextInput id="createDataTextInput" text="{createDataResult.lastResult as int}"/>

              </s:FormItem>

          </s:Form>

      </s:View>