2 Replies Latest reply on Dec 31, 2011 8:04 AM by Rick Gerard

    After Effects CS5-best settings for rendering many large files after multiple passes with the clone

    Postfade Level 1

      I have a moderate level Quad core PC,specs below, with 24Gb of RAM.

      I am processing sequences of timelapse photos brought in from Adobe RAW as either a raw sequence at the original 5K res (Canon 5D2) or as 4K 16bit TIFFs. There are typically between 400-500 shots in each sequence.

      I use clone brush in AE CS5 to remove 'stray objects' such as birds, people or vehicles from frames.

       

      I can succesfully process these if I only have to clone out the odd object from a sequence, but occasionally I require to remove something on multiple frames. This might be a car that drove into shot and stayed for say 200 frames before driving away again.

      The clone tool lets me paint out the arrival and then the parked vehicle by successively using the previous frame as the source. However at some point, even with say 16-20 Gb set as the AE memory, the program will get choked and start to crawl. This knocks on to the final render, when I will get outragous times for rendering even single frames, say 3 hours per frame etc.

       

      I assume that AE is having to go back through many multiple source frames as the cloning that I have done is continually using the previous 'already cleaned up frame' as the source.So frame 150 is using frame 149, which used frame 148 etc.

       

      Observing the Resource Monitor as AE renders, I see not much Processor usage, tyically 20-30% but maxed out Memory. Lots of reading of files off disk, usually apparently 'random' Windows system files, but also lots or reads from the timelapse source files as well.

      I did get single render times down to 1 hour but then did more tweaking and haven't got back to anything better than 2.5 hours per frame since!

       

      Is there a better way of achieving what I want?

       

      My PC specs and set up: HP xw8600 with x5450 Quad core processor.
      24 Gb RAM set usually as 16 Gb for AE (3 cores) and 1 core with max 3Gb for other progs. Sometimes I have set this to up to 20Gb fror AE.
      Running Vista Business (yes I know Win7 would be better-but hey it's yet more money!).
      Nvidia GTX460 1Gb memory with Cuda 'hack'-which works well with PP CS5.

      Windows Page File set to about 20% more than Windows usually sets it to, on either separate SATA drive or dual with the Windows C drive.

      Source files on external USB 3 drive (pretty fast).

      AE render files on RAID 0 internal 7200 drive.

      AE output files to another external USB3 drive.

       

      Any suggestions for improving my set up would be appreciated, as I'm getting old watching AE render my projects!

        • 1. Re: After Effects CS5-best settings for rendering many large files after multiple passes with the clone
          Mylenium Most Valuable Participant

          Is there a better way of achieving what I want?

           

          Don't use AE? Just kidding, but your own analysis very much covers the facts already. Yes, it's AE going back and forth in time and yes, it's the holding of those frames in memory which is chewing up your memory. Depending on the situation you may look into patching up your disturbances with masked still images rather than cloning across the sequence, but beyond that I don't see much potential to make things more efficient. It's just AE trying to be über-smart with caching and then making a mess. The only other thing is the RAW import, which may consume unnecessary memory. Batching the files in Photoshop and only using PSDs or TIFFs in AE may squeeze out an extra GB of RAM. On that note also consider doing the cleanup in PS. After all, PS Extended does support video/ image sequences to some degree...

           

          Mylenium

          • 2. Re: After Effects CS5-best settings for rendering many large files after multiple passes with the clone
            Rick Gerard Adobe Community Professional & MVP

            You need to empty out the cache. There's a preference for this that can be reached by holding down the Cmnd/Ctrl + Shift keys and going to Preferences>General and clicking. At the bottom of the list you'll see Secret. Check Disable Layer Cache and set a low number for the number of frames you purge when making a movie.

             

            If this doesn't fix the problem while you're doing the cloning go to Edit>Purge and clear out the image caches.