3 Replies Latest reply on Jul 7, 2008 6:50 AM by arfore

    Error message trying to connect to LDAP

    ahowar7 Level 1
      Error creating class for plugin:

      com.macromedia.contribute.server.plugin.ldap.Users Config. No property for

      plugin_ldapUsers/userBranches


      Anyone have this error before and if so, what exactly does it mean? None of my network guys can figure it out. Help!
        • 2. Re: Error message trying to connect to LDAP
          ahowar7 Level 1
          I have read that documents 100 times. I can load a product called Softerra LDAP Browser and can browse my LDAP all day long. But I can not get CPS to connect. I have searched the web and even called Adobe partners for help and nothing. We really want to use the product, but if it doesn't work.....:(
          • 3. Re: Error message trying to connect to LDAP
            arfore Level 1
            The error that you are seeing is not actually related to the LDAP itself.

            I recently migrated from the default option of using the OEM JRun 4 instance to a different Java Application Server (JAS) for CPS. In fact I am running it on a "non-supported" OS as well.

            I ran into this error and tracked it down to a problem with the Java code on the server side. It appears that if your JAS is too new then the code for the LDAP plugin on CPS won't work.

            I successfully migrate all of my services from the OEM JRun4 instance running on CentOS 4 to a server running Solaris 10. The CPS stuff is running nicely under an installation of JBoss 4.0.2 GA. I tried using JBoss 4.2.2 but ran into the error that you did. I was able to run it all under an installation of WebSphere 5 Community Edition, but the e-mail user function would not work so I had to go back to the JBoss installation.

            What Application Server are you running this under? Check your logs for a clue as to what is going on. Please note that the logs are not set to be verbose by default, but this can be fixed. Check out my blog post on this:

            Enable Verbose Logging on Contribute Publishing Server

            Hope this helps.

            Andy