11 Replies Latest reply on Jan 25, 2011 10:07 AM by Dave McGovern

    Adding a New Folder in Project Manager Crashes RH

    lmarden Level 2
      For the past few days, I have been having problems creating new folders in RH 7, Project Manager. Sometimes, it works just fine, and I can add folders, drag topics into them, import into them, create new topics, whatever.

      But then sometimes, the project manager just goes to white and flashes at me for a while, then RH crashes. The only things I can see in the PM pane are the triangular colored icons that overlay folders / topic icons when they include conditional build tags. No topic names, no folder names, just a column of these triangles.

      When I come back into RH after the crash, most times there are topics to reimport and / or relocate. I have rebuilt the cpd file several times. Each time it seems to resolve the issue, but eventually another crash comes along as I try to add a folder.

      For the record, just updated to the new 7.02.001 a few minutes ago, but RH just crashed again. 3GB RAM, more than 40GB space available on hard drive. Nothing new on my PC that I can think of.

      Anyone else seeing this?
        • 1. Re: Adding a New Folder in Project Manager Crashes RH
          Moonlion2 Level 1
          I'm seeing something similar: I can't delete folders or files. Well, more accurately, I can't delete 99% of them. Every now and again, seemingly randomly, I can delete one. I always try to delete it first because I'm a masoptimist.

          What I've been doing is (trying to, it doesn't always work) move everything into a new folder called _Delete_Me in the hopes that, one day, a fix will be found and all those deleted topics and folders will finally be dealt with
          • 2. Adding a New Folder in Project Manager Crashes RH
            rhDrs
            Was there a solution posted for this problem? I'm seeing these same symptoms.
            • 3. Re: Adding a New Folder in Project Manager Crashes RH
              nessfairgray
              I just experienced this problem too. I have never had a problem before - I was adding folders with no problems last week, now suddenly I can't add them at all. Not only does RH crash, but I can't reopen it unless I delete the folder in Windows Explorer, copy the backup of the next folder level up over the top of the 'broken' one, and then reopen RH. Does anyone know a solution?
              • 4. Re: Adding a New Folder in Project Manager Crashes RH
                Peter Grainge Adobe Community Professional (Moderator)
                LMarden follows the forums so hopefully she will post what solved it for her. Meantime I can only make suggestions.

                The fact that the folder is created in Windows Explorer confirms it is not a change of permissions.

                1] Is the project on your local drive?

                2] Have you tried renaming the CPD file in the root directory of your project and then reopening the project.

                3] After that it's your choice, either wait for LMarden or try an uninstall and reinstall.

                • 5. Re: Adding a New Folder in Project Manager Crashes RH
                  lmarden Level 2
                  for me, it was getting into the habit of regularly renaming or deleting the project's cpd file. haven't had this problem in a long time.
                  • 6. Re: Adding a New Folder in Project Manager Crashes RH
                    marilyn3000
                    Same Problem. I use Robohelp with Visual Source Safe. VSS is installed on a network server. It seems that when I try to add or remove folders, the communication between the VSS and Robohelp doesn't happen, either VSS is not sending a confirmation message, or Robohelp is not receiving it correctly. At any rate, I get the application hang, Not Responding, message and have to close and reopen Robohelp.

                    When I reopen, the folder is on the OS and in VSS, but not listed in Project Manager.

                    Interesting that the folder IS listed in the .fpj file, but doesn't appear in Project Manager.

                    I have to rename the .cpd file
                    • 7. Re: Adding a New Folder in Project Manager Crashes RH
                      rhDrs Level 1

                      Thanks all for your information.

                       

                      Running RH 7.02.001

                      9 GB free space

                      The project is local.

                      Renamed the cpd in the root directory of the project and reopened the project. The folder I added is there. The problem persists as I add another folder.

                       

                      DID NOT YET uninstall and reinstall. I hope that's the solution. Copied the project and worked on the copy:

                      1. Renamed the cpd.

                      2. Opened the RH project and added the folder. Didn't give it a name. It was still New Folder.
                          The project turned white as described above.
                      3. Exited RH by the x close button.

                      4. Renamed the cpd.

                      5. Opened the RH project.
                      6. Renamed the folder (not a necessary step, wanted to see if I could do it).
                          The project turned white.

                      7. Exited RH by the x close button.

                      8. Renamed the cpd.

                      9. Opened the RH project. The project had both the original folder, New Folder, and the renamed folder.

                          Deleted New Folder without the project turning white.

                      9. Imported topics into the renamed folder, and generated Help.
                         The new topics were in the Help. The project is running as expected. I'm not confident enough to use it though.

                      • 8. Re: Adding a New Folder in Project Manager Crashes RH
                        Amebr-ke0mH4 Level 2

                        We've recently been having this problem with one project.

                         

                        We tried so many things including removing spaces and special characters such as & and + from the file names (a lot of this was done by people who didn't realise this can be problematic in web based files.), using a shorter directory structure, even replacing colspan and rowspan tags, in case this was a return of the bug from RH6.

                         

                        Eventually I got a test project not to crash when adding a new folder - no spaces, special characters, row/colspan. It did take 15 min on the first attempt to add a folder after deleting the cpd, but after than, it was quite quick.

                         

                        To throw a spanner in the works, I then got an old version of the project, pre-file renaming, and tried the same thing and it also allowed me to create a folder, again with the 15min wait if the cpd file had been deleted. My colleague is currently on leave, so haven't been able to find out if they have the same experience yet.

                         

                        So perhaps just try leaving the computer for 15-20min and see if it comes back. I timed it and it was always pretty close to 15min, so try not to be impatient. :)

                         

                        Other than that, maybe ensure you don't have spaces or funky characters in file names.

                         

                        Amebr

                        • 9. Re: Adding a New Folder in Project Manager Crashes RH
                          Dave McGovern Level 1

                          I'm just wondering if anyone has found a cause or solution of this issue?

                           

                          I'm experiencing it too with one of my projects (currently, I'm on RH8.02.202 on Win7/64, but I've also experienced it in RH7 on WinXP/32, FWIW).

                           

                          Some other details:

                          • My project is on my C:\ drive.
                          • The folder names are all comprised solely of alphanumerics and underscores.
                          • I've deleted both the PSS and CPD files without any noticeable positive effect.
                          • Since I've been on RH8, the project is set to rebuild the .cpd cache upon opening, but I've also tried deleting it (this might be redundant, but I figured the RH "rebuild" might be different from generating a brand new one).
                          • After I force RH to close, the folder is there when I reopen the project, and the folder behaves normally.
                          • The project resides in the standard "My RoboHelp Projects" folder.
                          • The problem seems to be isolated to this project, which is my largest (~2065 topics in ~85 folders)

                           

                          I'm at the point where I just automatically force RH to close after I create a folder rather than waiting to for the application to become "officially" non-responsive.

                           

                          Are there any other files I might try deleting or examining?  I've poked around in the .xpj, .fpj, and .hhp files, but I don't see anything odd. I compared my old .pss with the new one RH created, and they were identical.

                           

                          Thanks!

                          Dave

                          • 10. Re: Adding a New Folder in Project Manager Crashes RH
                            Peter Grainge Adobe Community Professional (Moderator)

                            Dave

                             

                            It's late here but I've seen this a couple of times. I've asked one person to come back to me with what happened in their case but I've also found another thread.

                             

                            I'm not entirely sure the circumstances are the same but try this using a copy of your project, nothing to lose that way.

                             

                            1. Open the project and create a CHM with no build expression. Doesn't matter what your normal output is, create a CHM.
                            2. Close RH
                            3. Trash both the XPJ and CPD and open the project with the HHP file.
                            4. See if you can create a new folder.
                            5. If it has worked, see Opening Projects on my site re repairing things that may have been lost. That also describes this process in more detail.

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                            @petergrainge

                            • 11. Re: Adding a New Folder in Project Manager Crashes RH
                              Dave McGovern Level 1

                              Hi, Peter -

                              Thanks for the suggestion.  I'm going to try to set aside some time to try this later today. I'll report the results here.

                              Regards,

                              Dave

                               

                              UPDATE:

                              The proposed solution worked for me.  As the steps above note, this can cause certain parts of the project to get lost. In my case, the following items were missing:

                              • Conditional Build Tags
                              • Master Pages
                              • Alternate TOCs
                              • Single Source Layouts
                              • User Defined Variables
                              • My default SSL and default starting topic settings

                               

                              In most cases, I was able to restore these items by reverting the approriate rh*.apj files. In the case of the alternate TOCs and the default SSL/topic settings, I copied/pasted them in from the original .xpj file.

                               

                              To check the results, I ran a couple of reports (Unused Topics and Missing Topics, Broken Links), and I compiled a couple of layouts. I then created a new folder and RH behaved normally.

                               

                              As a final note, the procedure "touched" pretty much every HTML topic in the project, which resulted in a massive commit to my repository upon completion.

                               

                              Message was edited by: Dave McGovern