1 Reply Latest reply on Jan 3, 2012 12:31 PM by Peter Spier

    Slow Typing

    RTS_Engineering Level 1

      I kind of solved this problem, but I would also like to know if there are better solutions.

       

      A couple weeks ago I encountered really slow typing in InDesign. I never figured it out, but eventually it corrected itself. (BTW, exporting to IDML did not correct the problem.) Last night everything was working great with InDesign and a 15 chapter book with several chapters open. However, this morning when I restarted InDesign, it was horribly sluggish with typing (2 seconds per character).

       

      I started by looking for any preferences that could have gotten changed late last night. Then looked through the document for what could vary there too (such as no overset text). The only obvious change since last night was that I didn't have all of the other documents open while working on the current document.

       

      Suspecting it was the cross references, I updated all cross references in the book. This did not correct the problem. I deliberately did not open any other document until after I tried everything else first. As soon as I did open the 2 other chapters that I was linking into, the slow text problem went away. I then closed those two chapters, and the slow text returned. I then opened each of the 2 linked chapter separately, and the slow text remained. It was only when BOTH of the linked chapters were open that the normal typing speed returned.

       

      Right now it is not a big deal because only 2 other chapters are complete enough to link into. However, as this project progresses, there will likely be cross references to many chapters, and it will be more of a pain to have to open all of the documents in order to edit a single document.

       

      Could there be a setting somewhere that is causing ID to constantly update cross references with each key stroke?