3 Replies Latest reply on Jan 4, 2012 11:21 AM by Joel Cherney

    InDesign CS5.5 doesn't honor original Language (for spelling)

    diegoimas

      I'm using InDesign CS5.5 and always import .DOC and .RTF files. The default language in the "character" tab is Spanish. So is the default paragraph style. However, most of the times I import these files they are placed with English, Estonian, Croatian, etc., etc., etc. I have to change it almost in 90% of the files I place. And if I place the same file more than one time, it get placed with different languages every time. I've cheked the original .DOC and RTF files and are in Spanish dictionary.

       

      Is that a bug? Am I doing something wrong?

      Thanks,

      Diego

       

      InDesign CS55 / Windows XP

        • 1. Re: InDesign CS5.5 doesn't honor original Language (for spelling)
          Joel Cherney Adobe Community Professional & MVP

          Can you post one of these Word files that does this to you? Are you working with lots of Word files from lots of different people? Could it be as simple as corruption in the normal.dot off of which these Word files are based? Because I place multilingual Word files day in, day out and I've never seen any incorrect language settings. (But then again, the first thing I do when I place a translated  RTF is "clear overrides," and usually my paragraph styles are all Based On a single master where I specify the language and all of the other parastyles all inherit that language setting. So if this is a common issue I'd never see it.)

          • 2. Re: InDesign CS5.5 doesn't honor original Language (for spelling)
            diegoimas Level 1

            Here is the link: http://dl.dropbox.com/u/25396361/Amadeus%201174.rtf

            So far I don't have control whether they star wrinting in template file or if the copy and past text with styles.

            I also override all styles when applying. The only thing, so far, that doesn't work is the language.

            • 3. Re: InDesign CS5.5 doesn't honor original Language (for spelling)
              Joel Cherney Adobe Community Professional & MVP

              I also override all styles when applying. The only thing, so far, that doesn't work is the language.

               

              I placed that file into CS5.5 and it comes in with English in the Normal style. The Normal style in Word is also defined as English. Something is very wrong, here. You can define the language in the InDesign paragraph style, so if you clear the overrides then it must-by-definition have the language you specified. You say it's not, so something is wrong with either your INDD files or your install of InDesign. I don't see any of the funky language-redefinition behavior when I place your Word file into ID. The Normal style declares it to be English - I clear overrides and the text gets marked with English.

               

              If this happens to you in a new InDesign file, I'd say that you should try replacing your preferences, reinstalling, that kind of thing. If you are working with templates or re-using INDDs, you may try exporting to IDML and re-opening in CS5.5.