4 Replies Latest reply on Jan 11, 2012 9:24 AM by bmilesp

    Flex 4.6 upgrade, AIR Crashes When attempting to debug

    bmilesp Level 1

      I've just updated to Flex 4.6 and when I try to debug or run the app, air crashes and sends the following info. Does anyone have any ideas how to fix this issue?:

       

       

      Process terminated without establishing connection to debugger.

       

       

       

      Launch command details:  "C:\Program Files\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\bin\adl.exe" -runtime "C:\Program Files\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\runtimes\air\win" -profile mobileDevice -screensize 320x460:320x480 -XscreenDPI 163 -XversionPlatform IOS C:\bp\mobile_apps\WwHSuite\WwH\bin-debug\WwH-app.xml C:\bp\mobile_apps\WwHSuite\WwH\bin-debug

       

       

       

      Problem Event Name:APPCRASH
        Application Name:adl.exe
        Application Version:3.1.0.4880
        Application Timestamp:4eb7612e
        Fault Module Name:Adobe AIR.dll
        Fault Module Version:3.1.0.4880
        Fault Module Timestamp:4eb75fb9
        Exception Code:c0000005
        Exception Offset:000a8a5b
        OS Version:6.0.6002.2.2.0.768.3
        Locale ID:1033
        Additional Information 1:4ec5
        Additional Information 2:ef785832683e1b4fae1b2e480d9b0736
        Additional Information 3:ef3b
        Additional Information 4:cf6a107bb0e08d9752dd0debda56883d

       

       

      Read our privacy statement:

        http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

        • 1. Re: Flex 4.6 upgrade, AIR Crashes When attempting to debug
          Deke Smith Adobe Employee

          Your application *-app.xml file, when created with Flash Builder 4.5, uses the AIR 2.6 namespace:

           

          <?xml version="1.0" encoding="utf-8" standalone="no"?>

          <application xmlns="http://ns.adobe.com/air/application/2.6">

           

          For Flash Builder 4.6, it needs to use the AIR 3.1 namespace:

           

          <?xml version="1.0" encoding="utf-8" standalone="no"?>

          <application xmlns="http://ns.adobe.com/air/application/3.1">

           

          Usually, but not always, it has a compile error (see: http://forums.adobe.com/thread/935295). Occassionally it will get past compiling and have this problem. There are other things that could cause this error, but this is the one thing I have come upon most often when going from Flash Builder 4.5 to Flash Builder 4.6.

          • 2. Re: Flex 4.6 upgrade, AIR Crashes When attempting to debug
            bmilesp Level 1

            I've already changed the namespace to 3.1 as suggested, still crashes every time. Any other ideas?

            • 3. Re: Flex 4.6 upgrade, AIR Crashes When attempting to debug
              Deke Smith Adobe Employee

              It becomes a matter of eliminating other possibilities, then.

               

              Confirm that you have the WwH-app.xml file within your bin-debug directory. Within that file is a section that should look like:

               


              <initialWindow>


              <!-- The main SWF or HTML file of the application. Required. -->


              <!-- Note: In Flash Builder, the SWF reference is set automatically. -->


              <content>WwH-debug.swf</content>

               

              Where I have WwH-debug.swf, you should have the name of the SWF for your movie. Make sure that SWF is in bin-debug folder.

               

              If that is OK, the SWF may be crashing while it is bootstrapping. Put a SWF you know works in the bin-debug and go to the WwH-app.xml in the source directory, make a copy of it and temporarily change the value in the <content> element to this test SWF. The content will be [This value will be overwritten by Flash Builder in the output app.xml] unless you have changed it.

               

              If the test SWF loads then that means your application is crashing during bootstrapping and there is something within the app that is having a problem.

               

              If it is still not loading, there may be something within the *-app.xml that is not working. Make a copy of WwH-app.xml within the source directory, create a new test project, copy the contents of the new project's *-app.xml file into WwH-app.xml and run it. If it runs, change the test *-app.xml step by step until it matches the original WwH-app.xml.

              • 4. Re: Flex 4.6 upgrade, AIR Crashes When attempting to debug
                bmilesp Level 1

                Hi Deke, please see my latest post in this thread regarding the same issue: http://forums.adobe.com/message/4129804#4129804

                 

                For me, a matter of running Help -> Software updates seemed to do the trick. more details in the thread.

                 

                Thanks for your help.