2 Replies Latest reply on Jan 14, 2012 2:53 AM by JeffW.

    java.lang.NullPointerException Animation start problem

    JeffW. Level 1

      hi,

       

      after I finally managed to install Flash Builder 4.6 , I am getting an error as shown in the screenshot, ech time I compile

       

      'Animation start' has encountered a problem.

      An internal error occurred.

      java.lang.NullPointerException in FB 4.6

       

       

      Screen shot 2012-01-10 at 10.54.04.png

       

      This happens in a totally blank new project as well as in an existing older one, and in an Actionscript Mobile project as well as a Flex project.

       

      Btw, I can still compile the project, and the console doesn't show the error. I haven't tried yet to package a mobile project  to see if that still works.

      But it is quite annoying of course to get that error popup at every compile. Could this be a bug?

        • 1. Re: java.lang.NullPointerException Animation start problem
          JeffW. Level 1

          I just packaged and uploaded  a project to my iPad. It works except that it doesn't listen to mouse events anymore

           

          stage.addEventListener(MouseEvent.CLICK,onClick);

           

          The click event works when i compile on the desktop, but no luck with tapping the iPad to activate that listener...

          Changing it to TouchEvent doesn't help.

          I also uploaded the apk of the same project to my HTC, where the tapping does work correctly.

           

          And when exporting to package an ipa and an apk file, i'm getting the error again, twice, for each platform once i guess.

          Any idea where the Animation start error comes from?

          • 2. Re: java.lang.NullPointerException Animation start problem
            JeffW. Level 1

            I was using the Eclipse app that comes with Flash Builder 4.6 in the eclipse folders.

            Then I downloaded Eclipse 3.7.1 32 bit and ran the Adobe Flash Builder 4.6 Plug-in Utility in the Flash Builder uitilities folder,

            like I used to to with previous Flash builder versions,

            and this version of Eclipse with the FB plugin runs fine, all the problems are gone...