1 Reply Latest reply: Jan 11, 2012 8:17 AM by RoboColum(n) RSS

    Incomplete TOC in all help files in one context

    RoboColum(n) Community Member

      The problem

       

      We have hit an issue where the TOC of all our help files are truncated. This is true whether the help file is called from the application or the help file URL pasted into the browser. In addition the search and index only work for the topics displayed in the TOC. However if a topic is the TOC has a link to a topic that isn't displayed in the TOC, the link works. This is also true of all users regardless of what browser or browser version they use.

       

      Background information

       

      We are using RoboHelp Server 8 with SQL Server 2008 R2. Help files published using RoboHelp 8 (fully patched). Each help file is a merged project of between 12 and 15 RoboHelp projects. Each help file version is published to its own unique area. We currently have only the one context which contains all 17 areas. The robohelp.server.properties file uses the "reindex = false" parameter. Additionally the Tomcat proprties has an initial memory pool of 256 MB and a maximum memory pool of 512 MB.

       

      Resolution?

       

      We've checked the server and all the files are there. The entire TOC is displayed if you launch the help file from the Web Administrator or manually launch the start file. Deleting the output and re-publishing doesn't work. However if we created another context and published to there, everythign worked although we only tried this with one area's project output. The only way we could resolve this issue was to delete all the output from the server, complete with the accompanying area, recreate each area and regenerate / republish the output. Quite an undertaking for a series of projects this size! Nothing else seemed to work. This brought things back to where we were. However as soon as we tried doing anything in the Web Administrator, the problem reoccured although only on the one area we were working on.

       

      Questions

       

      As the issue seems to be related to a single area and only happens with the 17th project present, we are left with the nagging suspicion that the issue may be some sort of limit. Before I send our log files to Adobe to see what they can find, I thought I'd reach out to see if anyone else has experienced this. BTW the total disk space taken up by the context is now in excess of 1.5 GB.

       

      Best practice?

       

      Going forward we were planning to have a separate context for each of our products / major product versions. It looks like our hand could be forced into adopting this approach earlier than we wanted to. However I'd be grateful if others would post how they manage thier contexts.