2 Replies Latest reply on Jan 12, 2012 7:00 PM by Rick Gerard

    solid 3d issue

    Arrakis Level 1
      I have been following a tutorial using the camera with some text to create a 3 D effect but I had the following issue.

       

      I create a comp
      I created a solid and added a ramp gradient for my background
      I created a camera layer
      I created a null object and parented the camera to it - turned on 3d
      I created a text layer - turned on 3d
      When I change my camera view the ramp effected solid disappears and the comp background shows.
      If I toggle the transparency then there is no background at all.
      If i use 3d mode on the solid I can see it but I don't want the solid to be 3d I want it to be 2d like the comp background

       

      Where am I going wrong?

       

      I noticed that in the tutorial when he created the comp there was no choice in his settings to choose a colour. Maybe older versions didnt automatically create a background??  If I cant keep my solid background layer in 2d then how do I add a ramp to the comp background?     Cheers

       

        • 1. Re: solid 3d issue
          Dave LaRonde Level 6

          Precomp the solid with the ramp effect and use it in your main comp.  Life will get better.  Don't forget when precomping to move all attributes to the new comp.  Reset the layer's transform properties before precomping, too.

          • 2. Re: solid 3d issue
            Rick Gerard Adobe Community Professional & MVP

            When I change my camera view the ramp effected solid disappears and the comp background shows.

            This is the normal and proper behavior. Your 2D layers only show up under Active Camera or Camera. The other views, Front, Top, Custom, are only there to aid in positioning layers in 3D space. These other views won't render, but they will ram preview so many inexperienced users will set up a project using one of the custom views and then wonder why the rendered movie doesn't look like their project.

             

            Only the Active camera renders. From one of these other views you can look at each camera and each layer in your composition but you won't see the 2D layers at all.

             

            Only the top camera in the timeline will be the Active Camera and that's the only view that will render when you output your movie. You can cut between cameras by adjusting the in and out point of the camera layers.

             

            compViews.png

            Custom view 1 shows both cameras. Camera 2 is the blue one (you can change the color of your wireframes). Camera one is the orange one. Only Camera 2 will render, but I can select Camera one and see the 2D gradient background.

             

            Screen Shot 2012-01-12 at 6.50.49 PM.png

            But only the active camera will render so my completed project will look like this:

            Screen Shot 2012-01-12 at 6.51.22 PM.png

             

            You can see the gradient behind the floor that I added to the comp to give a sense of reality to the 3D text layer. I have view camera wireframes set to always on in the View Options because that's the way I prefer to work. The wireframes won't render, or ram preview.