1 Reply Latest reply on May 28, 2013 6:49 AM by nebbb

    Amazon Kindle problem using Flash Builder 4.6

    MintDouble

      Is there a way to specify a version of Air 2.7 using Flash Builder 4.6?  This would be handy for getting apps accepted by the Amazon App store for the Kindle.  Recently, I had an app accepted into the Amazon App store.  However, the App needs to use a version of Air that preceeds Air 3.1.  The version that I was advised to use is

      Adobe AIR v. 2.7.1.1999.

       

       

       

      I tried changing the 2nd line in the prog-app.xml file from:

      <application xmlns="http://ns.adobe.com/air/application/3.1">

       

      to

       

      <application xmlns="http://ns.adobe.com/air/application/2.7">

       

      However, this change led to an error:

      "See details for more information.

        Namespace 2.7 in the application descriptor file should be equal or higher than the minimum version 3.1 required by Flex SDK. "

       

      I recall that there was a temporary workaround for a similar problem with the Blackberry tablet OS.  The Blackberry OS problem was later solved and the fix is no longer necessary.  Perhaps, we need a work around for the Amazon Kindle to force the Flash Builder 4.6 to compile a release with Air 2.7.1.xx?

       

      Any ideas how to make this happen?