8 Replies Latest reply on Jan 30, 2012 5:45 PM by N Griffin

    Ubuntu 11.10, Flash Access and DRM




      I'm attempting to play a video download I purchased at a British video-on-demand service called Digital Theatre. The service uses a player which is an AIR application:




      DigitalTheatre uses DRM with Flash Access.


      I have Ubuntu 11.10 64bit and flash plugin 11. I successfully installed both the latest available Adobe Air version for Linux as well as the player. For Flash Access support, I followed the findings reported in the last post in this thread: 




      The adobe-flashplugin package and HAL are installed (I also tried the flashplugin-installer from Ubuntu repositories). The test video mentioned in the first post of the thread works fine, and DRM events show no errors. However, when attempting to play the video purchase I get "Unfortunately the playback has failed. You are not authorised to view this production". I can't see anything informative in the Adobe Air install log, and running the player from command line gives no data. Previously I had Arch Linux installed, and there in command line I saw DRM error id 3344.


      Attempting to launch the f4v file of the purchase in Firefox, it complains that the following two plugins are missing (and cannot be found in the search):


      video/x-gst-fourcc-encv decoder

      audio/x-gst-fourcc-enca decoder


      I have a 32 bit Ubuntu 11.10 on my netbook, the same version of flashplugin and with HAL installed, and there I can play the video purchase without problem. This would indicate that it's a 64 bit issue, but I'm puzzled as to why it is not working on my 64 bit machine, since the writer in the above thread apparently was able to solve the problem with HAL and adobe-flashplugin and since I can play the test video just fine.

        • 1. Re: Ubuntu 11.10, Flash Access and DRM
          chris.campbell Adobe Employee

          Hi Maria,

          I unfortunately don't know enough about Linux to be of any help here.  I'll run this by one of our Linux guys to get his take.  Would you also mind creating a new bug with your system details and a link to this thread over at bugbase.adobe.com?




          • 2. Re: Ubuntu 11.10, Flash Access and DRM
            libflashplayer.so Adobe Employee

            a drm error 3344 would suggest that the player you are using doesn't match the voucher you have downloaded.  make sure you are running a release version of the Flash Player, not a beta.


            determine running version



            next, delete the contents NativeCache



            reattempt to play the content.

            the drm module and voucher files will be downloaded.


            hope this helps...

            • 3. Re: Ubuntu 11.10, Flash Access and DRM
              MariaNiku Level 1

              Yes, I have done as instructed. Flash version is I had tried deleting the contents of the NativeCache before. No change.


              I am noting that the test player in http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html# with test video http://drmtest2.adobe.com:8080/Content/anonymous.f4v also gives the error #3344 but then upates the drm module and the voucher files. However, for whatever reason, the player is unable to update them either in Ubuntu 11.10 or Arch Linux. 


              For further info, in Arch Linux the player shows "Unfortunately the playback has failed. You are not authorise to view this production" and in command line I see the following:


              DRMVideoPlayer preloadEmbeddedData(file:///home/maria/Digital%20Theatre/Library/f2821d4a-f1c8-457e-b8b5- 0bd740c2006d.f4v)

              PlaybackScreenMediator showBuffering()

              PlaybackScreen showBuffering()

              DRMVideoPlayer onEvent() drmError by NetStream

              DRMVideoPlayer Netstream DRM Error Event: drmee.errorID: 3344

              DRMVideoPlayer Playback failed You are not authorised to view this production

              PlaybackScreen onEvent(error)


              Occasionally, the player only shows "Checking DRM license", with the same as above in command line but continuing with:


              DRMVideoPlayer onPlayStatus()

              DRMVideoPlayer onPlayStatus no drm restrictions

              DRMVideoPlayer setupVideo()

              DRMVideoPlayer setVolume(1)

              DRMVideoPlayer play()

              PlaybackScreen onEvent(stateChange)

              VideoControls setPlaying()

              PlaybackScreen clearFeedback()


              The video does not play this time either, however.

              • 4. Re: Ubuntu 11.10, Flash Access and DRM
                libflashplayer.so Adobe Employee

                i have reproduced your issue on Ubuntu 11.10 and entered an internal bug #3097114.  you won't have access to the bug, but if you would like to be notified you can enter a bug in our external bugbase. 




                let me know the bug number or that you posted and i'll bug group them.

                • 5. Re: Ubuntu 11.10, Flash Access and DRM
                  libflashplayer.so Adobe Employee

                  it turns out i did not have HAL installed.  after applying HAL 0.5.14-6 and verifying my flash version install 11,1,102,55, the video plays as expected (see screenshot).


                  Screenshot at 2012-01-25 153721.png


                  would you mind to confirm your installations through the Ubuntu Software Center?  make sure to have the Partner repositories enabled and search on Flash Player 11 and HAL respectively.  thanks...

                  • 6. Re: Ubuntu 11.10, Flash Access and DRM
                    MariaNiku Level 1

                    Yes, both are installed. As I said in the first post, I have had no problem playing the test video in the test player at any stage. There I get the #3344 error but the player then updates the DRM module as normal. It is only in the Digital Theatre player where the problem persists: for some reason, it is unable to update the module after reporting the #3344 error.


                    I can only assume that this is a 64 bit issue. Adobe Air is supposed to function fine in 64 bit with the appropriate 32 bit libraries installed but perhaps this is not quite so when the flashplugin is needed.


                    I have attempted to contact Digital Theatre's technical support, but it appears they do not have any linux knowledge, and I have not heard back from them after initial reply.

                    • 7. Re: Ubuntu 11.10, Flash Access and DRM
                      libflashplayer.so Adobe Employee

                      my apologies, i thought the issue was across both the browser and the air app.  btw, air linux support stopped at version 2.6.  i wanted to see if i could get the video to play on the same player swf on AIR, but was not able to complete my test using the AIR 2.6 SDK.


                      i will be on vacation the next two weeks, but will ask someone on the DRM team to follow up.

                      • 8. Re: Ubuntu 11.10, Flash Access and DRM
                        N Griffin Adobe Employee

                        Hi MariaNiku,


                        Apparently, when the x32 bit AIR is being run on your x64 bit OS, the DRM DLL is unable to access the x32 bit version of HAL.

                        Please try this workround to see if it addresses your situation.  Create a text document and put these commands into it:



                        export LD_LIBRARY_PATH=/usr/lib32

                        '/opt/Digital Theatre Player/bin/Digital Theatre Player'


                        After that, add executable permissions on the your document via chmod +x <your doc name> using Terminal.  You should be able to double click your doc and the DTP program should run.

                        If you launch your AIR application with the LD_LIBRARY_PATH to include /usr/lib32, then your application should work correctly.