4 Replies Latest reply on Jan 22, 2012 2:26 PM by geezer1943

    USCIS Form G-1145 won't open

    geezer1943

      I have a MacBook Pro running Mac OS X 10.7.2 and got an error page from this govt site saying I needed a later version of Adobe Reader. 

       

      So I downloaded Reader X 10.1.2, but still got the same message.  My wife's MacBook running Mac OS X 10.6.7 got the same result on both Safari and Firefox Browsers.  Help welcomed!