1 Reply Latest reply on Jan 17, 2012 12:09 AM by ockley

    Need some help with the autosave feature - Please!

    slnak_694

      Hello,

           I started an animation in flash recently and the autosave feature was turned on.  I had a good animation, but decided to play around with it a bit.  After a little while, I decided to call it a night and exited the program making sure NOT to save my work.  Upon opening that file the next time, I come to find out that Flash has autosaved my file while I was playing around.  Now I have a worthless animation, and have to start from scratch.  Is there any way to revert to a previous save, or autosave at this point, or am I about to do a lot of work again?

       

      Thanks anyone who can help.

        • 1. Re: Need some help with the autosave feature - Please!
          ockley Level 1

          As far as I know, the autosave function isn't able to track down previous versions of the saved document - that calls for a specified version control system. I believe that Flash only saves the file if it is told to. There is a few ways to enable or disable autosave:

           

          1. in the "New Document" dialog. you can choose to enable Auto-Save.
          2. In the "Document properties" dialog you can set the checkmark.

           

          If these are checked of, there isn't going to happen any auto saving. The problem may be, that there is also a topic called Auto-Recovery. Recovery and Save isn't the same when it comes to Flash, but people tend to think of them as the same. You set the Auto-Recovery feature in the Preferences under General.

           

          • Windows: Edit>Preferences : General>Auto-Recovery
          • Mac OS: Flash Professional>Preferences : General>Auto-Recovery

           

          Both has a default of 10 minutes, and can therefore confuse he user. Please look at the document to make sure, that you haven't unset Auto-Recovery instead of Auto-Save. you can do that by:

          1. Go to the preferences (Ctrl+U on Windows and Command+U on Mac OS) and check to see if Auto-Recovery is set.
          2. Go to the documents properties (Ctrl+J on Windows and Command+J on Mac OS) and check to see if Auto-Save is set.

           

          The first one (in the preferences) is ok to have set. It is the second one, that may have caused trouble for you.

           

          /ockley