15 Replies Latest reply on Jul 16, 2016 1:09 AM by Lame Tigrrrr

    InDesign mail merge:  changing the "record per page" function

    Everwood Farm

      I am a new InDesign user and having a problem that I have spent several days trying to correct.  Briefly, we are “attempting” to create our product catalog by importing our QuickBooks data (as a csv or txt file).  

       

      I think I have isolated the problem to the “records per page” setup. 

       

      For whatever reason, when I open the .csv or .txt file (Window > Utility >Data Merge),

      From the Data Merge Panel, I am selecting the source file and the “Create Merged Document” box starts. 

       

       

      However, ID is defaulting to one record per page.  When I open the Multiple Record Layout tab I get “… optiion disabled because single record is selected…”

       

      I have spent several days reading every post I could find on this and I am going brain dead.  Can anyone help me here ?

       

      Thanks in advance for your time and attention.

        • 1. Re: InDesign mail merge:  changing the "record per page" function
          Peter Spier Most Valuable Participant (Moderator)

          On the first tab, labeled Records, there's a drop-down in the middle of the tab to switch from Single Record to Multiple Records.

           

          You've read the help on Data Merge, right? If not, do so becasue it will save you a lot of grief ini setting up a multiple records merge correctly.

           

          Also, there is a bug in CS5/5.5 with previewing the merge. If you feel compelled to press the preview button do an Undo to get back to the previous view rather than trying to merge from the preview. Easier to take a leap of faith and just do the merge without the preview step.

          1 person found this helpful
          • 2. Re: InDesign mail merge:  changing the "record per page" function
            Jeffrey_Smith Most Valuable Participant

            For a Multiple Record Merge, you need to create the document size large enough to accomodate for the multiple placements. For example: you have a 3x3 area containing your variable placeholders. You want a multiple merge with 2 rows of records and 2 columns of records, for a total of 4 on a page with 0 space between each records. Create your document 6x6.

            • 3. Re: InDesign mail merge:  changing the "record per page" function
              Everwood Farm Level 1

              Hi Jeffrey,

               

              I think your on the correct path here, but I am a knew-bee (DEU) and not exactly sure how to interpret your advice.  When you say: Create the document as a 6x6, is this the Document Preset?

               

              Currently I have this set up with 1 column on a letter size page.  I have created an object containing the information for each record and I want to put 4 records per page.  The master is setup for left and right pages as below:

              Page-Master Layout_Page_1.jpg

               

              The resulting data merge is 8 copies of one record (4 records/page by 2 pages):

               

              Page-Master Layout_Page_4.jpg

               

              I am probably making the mistake of using MS Office logic in creating this (that has already bitten me a couple of times on this ID project) merge.

               

              Thanks again for your help.

              • 4. Re: InDesign mail merge:  changing the "record per page" function
                Jeffrey_Smith Most Valuable Participant

                For a multiple record merge, you only need to create "the object containing the information" once on your page, not 4 times. I recommend placing a frame (which acts as a bounding area) around the variable placeholders. This will help in determining the offset between records and placement on page.

                • 5. Re: InDesign mail merge:  changing the "record per page" function
                  Everwood Farm Level 1

                  Thank you for taking the time to assist me.  Remaking on your question/comment:

                   

                  >On the first tab, labeled Records, there's a drop-down in the middle of the tab to switch from Single Record to Multiple Records.

                   

                  Yes, but it is grayed out.  If you go to the multi record tab you get “… optiion disabled because single record is selected…”

                   

                  Page-Master Layout_Page_3.jpg

                   

                   

                  >You've read the help on Data Merge, right? If not, do so becasue it will save you a lot of grief ini setting up a multiple records merge correctly.

                  Yes, several times as well as postings at InDesign users groups and blogs.

                   

                  I think my MS Office logic is giving me brain block.  I know this is probably drop dead simple, and I will truly feel like a DEU when I see what my error is.... :-)

                   

                  Thanks again for your time.

                  • 6. Re: InDesign mail merge:  changing the "record per page" function
                    Jeffrey_Smith Most Valuable Participant

                    Here is an example of how your doc would be setup. The blue frame represents the frame I mentioned for positioning. Also, with multiple record merges, you can only do a single sided document. This will create as many pages as needed, but not a front and back scenario.

                     

                    merge.jpg

                    1 person found this helpful
                    • 7. Re: InDesign mail merge:  changing the "record per page" function
                      Everwood Farm Level 1

                      Yes, but I can't get to the multi record layout.  Please read my response to Peter on the same...

                       

                      But I think what your saying to me is that on the Master, I want to create a (text or graphics) frame and paste my object for the record in that frame?   Extending that, I would create 4 such frames per page with the record object ?  Currently, my master is set up with just the 4 record objects per page pasted to the Master...

                       

                      Thanks,

                      • 8. Re: InDesign mail merge:  changing the "record per page" function
                        Jeffrey_Smith Most Valuable Participant

                        Extending that, I would create 4 such frames per page with the record object ?

                        No, you only need one. The records that will populate down the page in postions 2, 3 and 4 are created automatically after you have selected from the Data Merge Panel Create Merged Document > On Records Tab (in middle of panel) Records per Document Page: Multiple Records, then Multiple Records Layout tab > you specify margins and spacing.

                        1 person found this helpful
                        • 9. Re: InDesign mail merge:  changing the "record per page" function
                          Peter Spier Most Valuable Participant (Moderator)

                          Please read the help topic on Data Merge. It really does do a great job of explaining the process.

                           

                          As Jeffrey says, for a multiple records per page merge you must have EXACTLY on set of placeholder frames, and enough space on the page to make at least one copy of EVERYTHING that you've put on the document page using the spacing parameters you choose. If you have an overlarge frame, or a stray object at the bottom of the page, this is going to affect the merge and placement.

                          1 person found this helpful
                          • 11. Re: InDesign mail merge:  changing the "record per page" function
                            Everwood Farm Level 1

                            Hi Jeffrey,

                             

                            Thank you for taking the time to put the video capture together.  Unfortunately, it is hanging up about one-third of the way through...   

                             

                            What it does show is opening a clean sheet, opening Pages, and then opening Data Merge....

                             

                            As you can see on the two screen shots below, I don't even get the Data Merge option on my Pages dialog...?

                             

                            Master Layout_1_Page_1.jpg

                             

                            Master Layout_1_Page_2.jpg

                             

                            So, I'm wondering if I have a problem with my ID install or have some how corrupted a setup or default file.... Hmmmm

                             

                            Thanks again, appreciate your help.

                             

                            Message was edited by: Everwood Farm I re-installed ID - probably didn't need to do this - and deleted the cache and setup files which was the culprit.  Now works perfectly ....  go figure :-)

                            • 12. Re: InDesign mail merge:  changing the "record per page" function
                              Everwood Farm Level 1

                              Peter,

                               

                              Worked through this with Jeffrey....  then read one of your postings on deleting the config files.  That is what my problem was and the data merge works perfectly. 

                               

                              NOTE For other users, I made the mistake of uninstalling and reinstalling....  That was not necessary.  Just clear your cache and setup files.

                               

                              Thanks to you and Jeffrey for your help.

                              • 13. Re: InDesign mail merge:  changing the "record per page" function
                                Jeremy AB Level 1

                                I was finally able to get the Multiple Records option enabled by deleting the second page in my document. However, even though I now have it set up for multiple records, I'm still getting 1 record per page (5 pages) instead of 5 records on one page. It is also offsetting the layout in the new file 1 inch down and .5 inch to the right instead of keeping it centered where I placed it. Margins are set to zero.

                                 

                                I'm basically setting up 10 business cards on one sheet. The template is set up, the names and addresses just need to go in.

                                • 14. Re: InDesign mail merge:  changing the "record per page" function
                                  Everwood Farm Level 1

                                  Hi Jeremy,

                                   

                                   

                                   

                                  You need to watch Episode 2: Automating a Catalog with Data Merge

                                   

                                   

                                   

                                  http://www.instantindesign.com/index.php?view=386  (you need to have an account and log in)

                                   

                                   

                                   

                                  Hope this is helpful,

                                   

                                   

                                   

                                  Dave

                                   

                                  Everwood Farm ®

                                   

                                  503-390-2637

                                  • 15. Re: InDesign mail merge:  changing the "record per page" function
                                    Lame Tigrrrr Level 1

                                    Hello, everyone! I'm not sure if this is still relevant considering that the question was posted more than three years ago. I just thought this would make the life of InDesign users a little bit easier.

                                     

                                    Anyway, these are purely don'ts when working with data merge.

                                     

                                    1. Do not create a facing pages document

                                    2. Do not create multiple-page document.

                                    3. When saving your document for the first time, make sure that the box that says "Always Save Preview Images with Documents" is not checked (see picture below). This will allow you to preview your data-merge document without "fear" (chuckles).

                                     

                                    indesign.png