2 Replies Latest reply on Jan 25, 2012 6:37 PM by dennismurphy1015

    Upgrade Problems

    dennismurphy1015

      Hi everyone.

       

      I am trying to upgrade an existing Flex 4.1 project to 4.6.  So I open up 4.6 and I do an "import".  It seems to work, but I get an error:  "Target runtime Apache Tomcat v6.0 is not defined".

       

      Additionally, I go to "open perspective" and look for the "Servers" tab (which has always been therin 4.0 and 4.1) and there is no "Servers" tab.  Typically I start Tomcat from the "Servers" tab.  So I am assuming these two issues are related....

       

      Can anyone shed any light on this, and what I have to do in 4.6 to use Tomcat to access my server side data?  I can't be the only one who has had this happen.

       

      Thanks very much in advance,

       

      Dennis

        • 1. Re: Upgrade Problems
          jtsattler

          Dennis,

           

          You are not doing anything wrong.  The problem is that you are most likely using the bundled copy of Eclipse that ships with FB 4.6, and that verson does not have the WTP (Web Tools Platform) stuff in it.  Adobe apparently packaged FB 4.6 under the assumption that someone else in your organization would be doing the server-side stuff and you will only be doing the client-side work.

           

          In any event, you need to go to the Eclipse web site and download the version of Eclipse that is appropriate for your server work.  Install it, and then go here for the instructions on how to install FB 4.6 as a plugin:

           

          http://kb2.adobe.com/cps/921/cpsid_92180.html

           

          This should solve your problem.

           

          Good luck!

           

          --Tom

          • 2. Re: Upgrade Problems
            dennismurphy1015 Level 1

            Thank you very much for this help.  I did what you said.  I got the new 3.7 Eclipse for J2EE and this solved my problem.  I never would of thought of this.