1 Reply Latest reply on Jan 24, 2012 9:05 AM by ace0215

    How to deploy a Flex application (Server Type ColdFusion) to production

    ace0215

      I had just posted this in the flex forum and then realized there was a Flash Builder Forum where this question might be more suited so I appologize for the double post.

       

      I have built a flex application using Flash Builder 4.6.  It utilizes ColdFusion Flash Remoting for its data services.  When first setting up the data services I had to set a bunch of properties in the flex server section.  Which I am not sure are all correct but the app does run and connect to the data services.  They were:

       

      Application Server type: ColdFusion

      Use remote object access service

           ColdFusion flash remoting

       

      Server Location:

           Deployed to Java application server

           Web Root: v:\inetpub\testFlex

           Root URL: http://myDevServerIP/

           ColdFusion Was folder: v:\CF9\JRun4\servers\testFlex\cfusion.ear\cfusion.war

       

       

      My question is now when I'm ready to deploy to my production machine and load the app onto a tablet or other computer, obviously the Root URL will be different something like http://myLiveURL.com.  Is this the only thing I change?  Do I even change it here or is there some other location?  Any other things I need to change?

       

      Thanks!

      Your help is much appreciated!

        • 1. Re: How to deploy a Flex application (Server Type ColdFusion) to production
          ace0215 Level 1

          So I tried modifying the root url to be my live production url and it broke.  I can no longer test the data services nor run the app.  I did notice that the _Super_XXX.as file no longer had an endpoint so I edited that file and then was able to run the app however I cannot test any of the dataservices any more.  I get an error:

           

          InvocationTargetException: There was an error while invoking the operation.  Check your server settings and try invoking the operation again.  Reason: java.net.MalformedURLException: no protocol.

           

          And then even if I try and set it back to my development server I still get this error.

           

          How can I do development on my development server then test it on my test server then deploy it to an app on a tablet that then would point to a production server for the data all the while being able to go back to doing more development on the development server?

           

          Please help!  I'm stumped!