2 Replies Latest reply on Aug 3, 2012 12:58 PM by gspieler

    Reader X - Right Click & Print not keeping defaulted "Fit" option.

    Rhodes.Richard

      Using Adobe Reader X (version 10.1.2) I have a number of PDF files to print and would simply like to right-click and print. However, the pages are cut off on the sides. If I open each document individually and click print (with a default Size Options = Fit), the documents print ok. How can I change the "right-click & print" option to default with Size Options = Fit?

        • 1. Re: Reader X - Right Click & Print not keeping defaulted "Fit" option.
          Rhodes.Richard Level 1

          Thanks, I found a solution.

          Foxit Reader

          • 2. Re: Reader X - Right Click & Print not keeping defaulted "Fit" option.
            gspieler

            I was having the same problem with a pdf printing system we've developed.

             

            We had been using the /n (new window) /t (print) parameters when calling Reader, but I thought it would be a nice change to simply emulate the right-click print with code to make it a little friendlier for upgrades.  While that mostly worked, I ran into a couple of issues.

             

            When the right-click print is done, it appears Reader uses the Reader defaults and doesn't look at your particular settings.  If, however, Reader is already open it does use your settings.  Occasionally, we received a corrupted or password protected file that we couldn't automatically process.  To solve this issue, I decided to print the pdfs serially and kill acrord32.exe after each print job.  Since I was killing after each print job, it never used my settings but alwasy the default Reader settings.

             

            In my case, I switched the code back to use the /n /t parameters and it is working fine again.

             

            So, in your case, if you leave Adobe Reader running, it might resolve your issue.

             

            The right-click print does /p /h behind the scenes.  Perhaps another option is to change the registry to use /n /t instead of /p /h.