4 Replies Latest reply on May 21, 2012 10:03 AM by rudytheelder

    Hyphenation problem! doesn't work...

    Soé-X

      Ok, I've been using paragraph styles and checked the hyphenate option and doesn't work.... did it manually and nothing, tried with other type, other text, other version od Indesign... and nothing!

      Please if someone know if there is something that may block it, I'll appreciate your help!

       

      Thank You

        • 1. Re: Hyphenation problem! doesn't work...
          Peter Spier Most Valuable Participant (Moderator)

          Lets get all the details, first. What version of ID? Do you have the latest patch? OS?

           

          Next, what language is assigned to the text? Highlight the word you think should be breaking, and look at the Character panel or the Control panel and check the language. A common trick to prevent hyphenation is to assign [No Language]. Also be sure that Hyphenation is actually enabled (double-check -- it might be enabled in the style, but turned off as a local override), and that No Break is not assigned to the word.

          1 person found this helpful
          • 2. Re: Hyphenation problem! doesn't work...
            Soé-X Level 1

            Thank you! I saw it was in " no language" and change it to spanish!! hehee! thanks!

            • 3. Re: Hyphenation problem! doesn't work...
              Peter Spier Most Valuable Participant (Moderator)

              Check your paragraph styles to be sure a language is applied, and you can use Find/Change to fix any words that have no language applied. Use the GREP tab and search for .+ and change to $0. In the find formatting choose [No Language] and in the change formatting choose the language of your choice.

               

              It's also possible that some words had a character style applied that specified the [No Language]. If that's the case it would be better to search for the character style rather than the [No Language] in the find options and and change the caharacter style to None in the cahnge uption rather than specifying a language. That way your paragraph and character syles will continue to work as intended.

              • 4. Re: Hyphenation problem! doesn't work...
                rudytheelder Level 1

                I had a similar issue that my hyphenation requests seemed to have no effect.

                 

                But my problem was that I had not selected the text that I wanted to hyphenate.  To fix this I used the Text tool clicked on a page and used Ctrl+A to "Select All".  Then I went to the Paragraph fly-out menu to get to the Hyphenation dialog, and now it's working.