1 Reply Latest reply on Jan 31, 2012 8:41 AM by Frustrated in AZ

    PRS-650 not recognised by ADE - HELP!

    Aliceonline

      I recently downloaded Adobe Digital Editions to enable me to read an ebook downloaded from the library. I imported this book into ADE and it appeared in the library.

      However, I want to read the book on my Sony PRS-650 and although the device shows up on my computer it does not appear in the ADE bookshelves.

      I registered with adobe and authorised my computer.

      I am working on an Mac, and following the advice on these forums I registered my ereader with the Sony website, setting up new account. I then thought that the advice online suggested I should have used my Adobe ID to log into the Sony site, so I deleted my account (which used the same details) and tried logging in with my Adobe ID, which didn't work.

       

      I also tried to click on the arrow next to the Library in ADE and Authorize computer, but there was no sign of the ereader and a box popped up telling me my computer was already authorised.

       

      Have you got any suggestions about how to proceed with this and get my ebook reader recognised?

       

      Thanks

        • 1. Re: PRS-650 not recognised by ADE - HELP!
          Frustrated in AZ Level 4

          Your ereader is on the Supported Devices list, so that's probably not the

          issue.

           

          Software could be an issue: what version are you running: Snow Leopard or

          Lion?

           

          Sequence is important in getting the hookup to work also.  You should have

          the device attached and recognized before you start ADE.

           

          Your registration with SONY could be a problem.  If you had the ereader

          attached at the time you registered, then SONY downloaded a small ID file

          to the PRS-650, and it's still there, regardless of whether you deleted

          that account.  It might make a difference - and then might not.  You'll

          find out when you get things going.

           

          And there's one more thing: check your MAC to see if the SONY Reader

          Library has been installed.

           

          Hopefully, there's a gem in this email and it will help you!

          ===========