0 Replies Latest reply on Jan 31, 2012 11:59 AM by stuckness879879

    "The installation of This application is damaged...." everytime I build with adt using ant...

    stuckness879879 Level 1

      So basically I can build the entire application with ant just fine except up to the point of packaging. I can't get consistent air builds with the ant script. If I just export to release in flashbuilder after running the script up to point to where I need to package...it works just fine though

       

      A snippet of the install logs...

       

      2012-01-31:13:11:05] Application Installer begin with version 3.1.0.4880 on Windows 7 x86

      [2012-01-31:13:11:05] Commandline is: C:\Source\ESManager\ESManager.air

      [2012-01-31:13:11:05] Installed runtime (3.1.0.4880) located at c:\Program Files (x86)\Common Files\Adobe AIR

      [2012-01-31:13:11:05] Unpackaging file:///C:/Source/ESManager/ESManager.air to C:\Users\stuckness\AppData\Local\Temp\fla82FA.tmp

      [2012-01-31:13:11:10] Application signature verified

      [2012-01-31:13:11:10] Unpackaging/validation complete

      [2012-01-31:13:11:10] Installed app (ESMain.dev.E2264762215296142788B65F717A5C51E123BA2D.1) located at C:\Program Files (x86)\ESManager_Development\ESManager_Development.exe

      [2012-01-31:13:11:11] Converting unpackaged application to a native installation package in C:\Users\stuckness\AppData\Local\Temp\fla99F4.tmp

      [2012-01-31:13:11:12] Native installation package creation succeeded

      [2012-01-31:13:11:12] Starting app update of C:\Program Files (x86). Updating from ESMain.dev.E2264762215296142788B65F717A5C51E123BA2D.1 version 1.1.74 to ESMain.dev.E2264762215296142788B65F717A5C51E123BA2D.1 version 1.1.75 using the source file at file:///C:/Source/ESManager/ESManager.air

      [2012-01-31:13:11:12] Installing msi at C:\Users\stuckness\AppData\Local\Temp\fla99F4.tmp\setup.msi with guid {27604778-1928-6588-1CA0-A0895A94C4D6}

      [2012-01-31:13:11:18] Launching subprocess with commandline C:\Program Files (x86)\ESManager_Development\ESManager_Development.exe

      [2012-01-31:13:11:18] Application Installer end with exit code 0

       

      I keep wondering if there is something wrong with this, but always builds just fine...it's just a problem when I run the air package...and it runs just fine if I don't run this section and just export to release in flashbuilder, but I'm trying to automate the process...

       

      <target name="package" depends=""

              description="Packages the build SWF file from a temp directory.">

              <exec executable="${FLEX_HOME}/bin/adt.bat" failonerror="true">

                  <arg line="-package"/>

                  <arg line="-tsa none" />

                  <arg line="-storetype pkcs12"/>

                  <arg line="-keystore C:\Source\ESHIPPING.p12"/>

                  <arg line="-storepass PASSWORD_HERE/>

                  <arg line="C:\Source\ESManager\ESManager.air"/>

                  <arg line="C:\ColdFusion8\wwwroot\ESManager-debug\ESManager-app.xml"/>

                  <arg line="-C C:\ColdFusion8\wwwroot\ESManager-debug \swfs" />

                  <arg line="-C C:\ColdFusion8\wwwroot\ESManager-debug \data" />

                  <arg line="-C C:\ColdFusion8\wwwroot\ESManager-debug \esicons" />

                  <arg line="-C C:\ColdFusion8\wwwroot\ESManager-debug \autoupdate" />

                  <arg line="-C C:\ColdFusion8\wwwroot\ESManager-debug ESManager.swf" />

              </exec>

          </target>