8 Replies Latest reply on Feb 6, 2012 5:38 PM by TaiWuWei1

    Problems with length of rendered video

    TaiWuWei1

      I'm encountering a very frustrating problem with the length of rendered video.  I am working on a project which involves syncronizing video created in After Effects with music using a VJ application (Resolume Avenue).  My process:

       

      1. I create a 4 beat loop in Ableton at 120 bpm.  This yields a wav file exactly 2 seconds long.  (2 beats per second, 4 beats.  I have verified the length of the wav file in Audacity to be exactly 2 seconds long.)

      2. I import this wav file into an After Effects project, then drag this into a 30 fps composition.

      3. I create video syncronized with this audio file.  When I RAM preview with loop enabled, everything looks good and is in time.

      4. I add this composition to the render queue.  Using the QuickTime output module, I enable export of audio, and render the file.

      5. I import this rendered video into another program.  (I have done this in Ableton and Resolume Avenue.  It doesn't matter which program; the end result is the same...)

      6. The rendered file has --too much time-- between the fourth beat and the end of the file.  All beats fall at the proper time within the file, but because the rendered file is just too long at the end, the loop falls out of syncronization.

       

      There is over a tenth of a second of time beyond 2 seconds.  I could manually trim the out point in the playback application for every video file I render, but this is far from optimal.  What am I missing?

        • 1. Re: Problems with length of rendered video
          Andrew Yoole MVP & Adobe Community Professional

          Is the actual duration of your comp 2 seconds, or does it finish at 2 seconds?  If the latter, you have an extra frame.

           

          Why not just shorten the comp until the resulting render comes out right?  Typically, the last frame should be 1 sec 24 frames (PAL) or 1 sec 29 frames (NTSC).

           

          Also make sure your other software recognises video at the same frame rate as your rendered files:  a 25 fps file in a 29.97 fps project will have timing issues.

           

          And finally, make sure you're not using a temporally compressed Quicktime format (like H.264 or MPEG4) which can screw up some types of software.  A codec like Animation (all keyframes), PNG or PhotoJPEG is the best option because each frame is stored independently. 

          • 2. Re: Problems with length of rendered video
            TaiWuWei1 Level 1

            Andrew: Thanks for the suggestions.  Unfortunately, I've made no progress.

             

            My comp duration:

            comp duration.jpg

             

            Using the Animation setting with a keyframe every 1 frames:

            quicktime settings- animation, all keyframes.jpg

             

            I get this in Ableton:

            clip in ableton 2.jpg

             

            It's not very easy clear in the resized picture above, but you can see the waveform ends where it should at the end of measure 1, but there is extra time at the end after the last transient.

             

            You can see the same thing in Resolume:

            clip in Resolume 2.jpg

             

            Reducing the comp size starts to bring the total clip duration closer to 2 seconds, but actually cuts into the end of the waveform.

             

            In trying to troubleshoot the source of this extra time at the end of the rendered file, I added a timecode layer to the comp, exported with the same settings as above, and imported into Ableton.  You can see below that the timecode ends where the audio ends... but the file is inexplicably longer than the original comp size.

            30 fps d&b, with timecode 2.jpg

             

            Any ideas?

            • 3. Re: Problems with length of rendered video
              Rick Gerard Adobe Community Professional & MVP

              What I need to see is a screenshot of your comp.

              • 4. Re: Problems with length of rendered video
                TaiWuWei1 Level 1

                Rick: Is this what you're looking for?

                full comp shot, small.jpg

                • 5. Re: Problems with length of rendered video
                  TimeRemapper Level 4

                  Have you tried rendering a .wav of .aif  (audio only module) using the render queue and importing it into your other software packages to rule out any possible issues with the Quicktime format?

                  • 6. Re: Problems with length of rendered video
                    TaiWuWei1 Level 1

                    TimeRemapper: I just tried that now... And the .wav exported from After Effects is a perfectly formed 2 second loop with no extra time at the end.  So what am I missing in the Quicktime settings that should prevent this from happening when exporting video?

                    • 7. Re: Problems with length of rendered video
                      TimeRemapper Level 4

                      It honestly might be something screwy with the format. Is it an option for you to render your audio and video as separate modules? It might be your most solid solution currently. Just out of curiosity, have you tried setting the keyframing on the compression to "auto" instead of "on every frame"?

                      1 person found this helpful
                      • 8. Re: Problems with length of rendered video
                        TaiWuWei1 Level 1

                        TimeRemapper: I was going to say that the problem would still be there with the video-only file, but I did myself a favor and checked it out.  Both video-only and audio-only renders come out at the appropriate length.  It is only with a combined audio/video render that the extra time gets added.  So to answer your question, yes, it is in fact an option for my particular project to render audio and video separately, although it wasn't my original intent to do it that way.  Now that I've given it some thought, though, I think it may work out for the best in the long run if I use that workflow...  (Your other question: yes, I tried rendering with auto keyframes.  Same result.)

                         

                        So, my problem is still a little unsolved, but the "work-around" is probably the better way of doing things - so thanks to all who helped.  If anyone has a suggestion as to why the audio/video renders have extra time tagged on, I'm definitely still curious!

                         

                        Note to anyone who is a Resolume user and like me is too impatient to read the manual: when doing your final render in After Effects, use the DXV codec in the QuickTime module.  This codec is good-to-go for Resolume without any tweaking of settings, but the main plus is that it enables Resolume to utilize the GPU for playback and takes a load off of your CPU.