2 Replies Latest reply on Feb 7, 2012 2:45 AM by Markusww

    Complex Itemrenderer (List within List), how can i disable the scroller?

    Markusww

      Hey Folks,

       

      so im struggeling for a while with a scrolling problem now.

      I'm developing a flex application with some complex views. On of the views is like a word document view. It pulls data from the database and represents requirement specification. You can also edit the data within this "word" view. It should basicially work like microsoft word. That view works fine but i have one issue with it: Scrolling!

       

      To realize that view i have created a complex ItemRendererClass that contains another complex ItemRenderClass. Imagine it like that>

       

      -List of chapters (itemrenderer)

      - Chapternumber + ChapterTitle

      - ChapterText

      - Chapterpicture

      - List of data (itemrenderer)

      - Requirementnumber

      - RequirmeentText

      - Pictures

      - lots and lots of attributes

      -...

       

      All in all I'm really happy how the "word" view&editor works but if im scrolling down and im over the second lists which represents the list of requirements i cant scroll anymore, when the mouse is out of the list item i can scroll again. What i have done is i use virtuall layout on both lists for performance reasons and the second lists height is a 100%, so the second scroller never appears. I have tried to disable the second scroller of the second lists with "this.scroller.setStyle('verticalScrollPolicy', 'off')". But nothing happens. What i want is a normal scrolling behaviour, means that it shouldnt matter where in the "wordview" the mouse is i want to scroll like it is one list and not 2 lists.

      I would appreciate a hint where i should look for advice, or maybe someone i the communitiy has faced the same problem.

       

      Thanks,

      Markus