33 Replies Latest reply: May 18, 2015 12:15 PM by fgallery2 RSS

    How to stop adding " copy" to file names?

    jacquilynw Community Member

      First off, I don't mind the save as a copy feature. If I have a psd file with layers and smart objects and such, and I Save As > JPG, I don't want the jpg open, I want the psd open. I like how PS does that behavior, but I don't like how that jpg gets " copy" added to it's file name. Yes it's easy to remove, but I'm using a batch action on over 300 pictures, I don't feel like renaming 300 jpg's. Yes it's supposed to be a safety net, but I basically never work from jpg's as original's, and if for some reason I do, I set them as read only and copy the files off to a safe location, so I don't need it.

       

      I know it's possible because my old school's computers with photoshop CS5 never saved jpg's with copy in the file name. So, how do I stop PS CS5 from adding copy to my file names? Because I need photoshop to not add copy to my file names on my work computer (and it's my old school, can't use their computers or ask someone why it's like that).

        • 1. Re: How to stop adding " copy" to file names?
          JJMack MVP

          Starting with Photoshop CS scripting has been a standard feature and a script named Image Processor has shiped with Photoshop. With each release of Photoshop since CS scripting support has been enhanced as has the Image Processor Script.  There are also better Image processor scripts that can be downloaded.  With CS5 you can even download one that is a Plug-in from Russell Browns web site it name is Image Processor Pro and after it is inatslled you will find it under menu File>Automate>Image Processor Pro and you will find the Image Processor script under menu File>Scripts>Image Processor.  Script can name saved files better than Action,  These Image Processing scripts can save and resize your images they can include actions you make during their processing.  Your action are easier to make for you they do not have to include any resizing naming and the actions do not require any save steps.  The Image Processor Pro script has more features then the standard  Image Processor script. Any Image Processor script can be used to do what you want to do.

          • 2. Re: How to stop adding " copy" to file names?
            Curt Y Community Member

            Are you using the batch process in Image Processor?

             

            Don't think that adds copy, although some processes do.

            • 3. Re: How to stop adding " copy" to file names?
              Noel Carboni Community Member

              I would hate it if I had to carve off "copy" every time.

               

              Funny thing...  I do File - Save As and choose JPEG all the time.  I never see it add "copy" to the filename.  NEVER.  I never thought about this until I went to reproduce this problem for jacquilynw above...

               

              What have I done to please the Photoshop gods?  I don't recall any checkbox that told the system to avoid putting "copy" in the filename.  Could it be because I have the operating system set up to show me file extensions?  Don't get me wrong, I don't want to change it to the behavior jacquilynw is seeing, but it would be nice to be able to tell her how to avert "copy" in the name!

               

              -Noel

              • 4. Re: How to stop adding " copy" to file names?
                Curt Y Community Member

                In the first screen of "save as" there is a box in options "save as a copy".

                • 5. Re: How to stop adding " copy" to file names?
                  Noel Carboni Community Member

                  That normally comes on (and is grayed out), the way I work - e.g., on 16 bits/channel master files and with multiple layers.

                   

                  But no "copy" shows up in the name...

                   

                  AsACopyOn.jpg

                   

                  -Noel

                  • 6. Re: How to stop adding " copy" to file names?
                    Curt Y Community Member

                    In PS clicked "save as" and I get this screen.  CS5.

                     

                    I see your "as copy" is grayed out.

                     

                    copy to.JPG

                    • 8. Re: How to stop adding " copy" to file names?
                      jacquilynw Community Member

                      JJMack:

                      I don't know anything about PS scripting, I've never tried to use it, what I need can be done via actions, and I don't have a week to stop and learn a new langauge. I don't need better control over file names, just for the file name to remain unchanged. Honestly I'd like to be able to make PS stop doing it at all times, because I never need " copy" in my file names and it's always annoying, but now it's finally getting in the way of a project at work so it's finally worth trying to fix.

                      • 9. Re: How to stop adding " copy" to file names?
                        jacquilynw Community Member

                        Curt Y:

                        My installs of PS always has the save as copy greyed out and checked when I have multiple layers and choose jpg from the drop down (even the old PS7 ones I used to have). Even the computers at my old school forced that check box to be checked, but they just didn't add " copy" to the file name. Like I said, the concept of saving off a copy doesn't bother me (instead of saving as a jpg then having a flat jpg open), what bothers me is the file name getting appended.

                         

                        Just off a guess it might be that way because you opened a jpg or flat psd and hit save as. Try something with layers. If it still doesn't force save as copy to be checked, then I'd love to know what you did to PS to get that to work.

                        • 10. Re: How to stop adding " copy" to file names?
                          Grant H Community Member

                          if you open the image.jpg in ps, and you try save a jpg copy with the same name it will add "copy" to the file name. This is because PS is working with the original JPG and saving as (with as a copy) effectivley creates a new file saves and closes it... it needs the original open.

                           

                          G

                          • 11. Re: How to stop adding " copy" to file names?
                            Noel Carboni Community Member

                            Seems to me that she's said she's opening PSDs with things that can't be stored in JPEGs, and when she goes to save them they have the word "copy" added to the filename.

                             

                            jacquilynw wrote:

                             


                            If I have a psd file with layers and smart objects and such, and I Save As > JPG ... but I don't like how that jpg gets " copy" added to it's file name.
                            ...
                            I basically never work from jpg's as original's

                             

                            Jacquilynw, just for clarity:

                             

                            1.  You are NOT actually clicking the [  ] As a Copy checkbox manually, right?

                             

                            2.  Are you seeing "copy" added to the filename when you open a PSD with things that can't be saved in a JPEG then just do File - Save As - JPEG?

                             

                            3.  On that system, do you have Windows Explorer Folder Options set so that you see the file extensions all the time (e.g., .jpg, .psd, etc.)?

                             

                            As I have said, I do NOT see "copy" in this condition, when I File - Save As - JPEG on my PC workstation running Windows 7 x64.  Clearly Photoshop is sensitive to something on the system that's averting this behavior, though I do not know specifically what.

                             

                            -Noel

                            • 12. Re: How to stop adding " copy" to file names?
                              jacquilynw Community Member

                              The photo's were jpg's, but then I did a batch action they turned them all into psd's. It coverts the bg layer to a smart object, does an image size to 200px wide, and a canvas size to cut off the edges a little. The action then saves the file as psd. The photo's all vary slightly, so I will need to nudge a few to center their face (hense the smart objects), but after that I'd like to just save them out using a batch action as jpg's for web use without renaming each file. That and the silly " copy" thing has always bothered me, I've just never needed it turn off like this before. I have another action made to save the psd's as jpg's, and I didn't change the file name, simply the folder location, and every time I try to use it the jpg's have " copy" in their file names.

                               

                              1. I'm not clicking that check box, it is disabled and checked for me. Sometimes when I save manually (using the ctrl+shift+S instead of the action) the word " copy" isn't added (though sometimes it is), but it's always added when I use the action. Even when I created the action to save from psd back to jpg, the file I used didn't have copy, but any file saved using the action has copy in the file name.

                              2. If I understand you correctly, then sometimes yes.

                              3. Yes, I always change that setting. I'm fully aware of what changing file extensions can do, and sometimes I need to do it, so I like seeing them.

                               

                              I'm running win7 on a 32 bit PC. Is that regardless of this like smart objects, layers, and adjustment layers? You call it a worksation, does that mean it's not your computer? Like I said the PC's at my school never did this dumb " copy" thing and I have no idea why.

                               

                              Thank you for trying to help me.

                              • 13. Re: How to stop adding " copy" to file names?
                                Grant H Community Member

                                how are you automating this exactly...

                                 

                                G

                                • 14. Re: How to stop adding " copy" to file names?
                                  Noel Carboni Community Member

                                  Thanks for the additional info... 

                                   

                                  A PC workstation is just a powerful PC, purpose built for professional work.

                                   

                                  Just to be perfectly clear, do I understand correctly that it's when you're using an action to do your File - Save As that you're seeing the "copy" added?

                                   

                                  I just recorded an action to do the same.  While I never see "copy" added during an interactive Save As, I definitely DO see "copy" added when it is done from within an action.

                                   

                                  I don't know of any way that this behavior can be changed, but we can hope perhaps to hear from Chris Cox, who knows the Photoshop internals.

                                   

                                  -Noel

                                  • 15. Re: How to stop adding " copy" to file names?
                                    jacquilynw Community Member

                                    I somestimes see it when I don't use the actions. I don't remember the conditions, but I know I've seen PS CS5 do it at some point.

                                     

                                    Yes, maybe he will drop in. If adobe has been trying to get rid of the adding copy thing, then maybe this is just a part of it they didn't remove yet? I think older versions of PS did it much more often. Honestly I wish it had been optional in the first darn place, but way too late for that.

                                     

                                    Thank you for your help Noel.

                                    • 16. Re: How to stop adding " copy" to file names?
                                      Curt Y Community Member

                                      Think I found it at this site

                                       

                                      Here is summary

                                       

                                      Anyway, I eventually found it nestled in the Layers Panel drop down menu. Maybe CS6 will manage to consolidate all the programs options into one central located, we can only hope :smile:

                                      The Solution (CS5)

                                      1. Click on the dropdown menu Photoshop CS5 Layers Panel Menu Icon to the right of the Layers Panel
                                      2. Select Panel Options near the bottom and you’ll get the “Layers Panel Options” window up (see right)
                                      3. Look at the bottom of the “Layers Panel Options” window to see where Adobe have hidden this little treasure
                                      4. Titled “Add ‘copy’ to Copied Layers and Groups” the new checkbox will default to ticked, simply untick it to enable one of the most powerful changes in Photoshop CS5 :cool:
                                      • 17. Re: How to stop adding " copy" to file names?
                                        Grant H Community Member

                                        thats just got to do with copying/duplicating of layers... not file names.

                                         

                                        G

                                        • 18. Re: How to stop adding " copy" to file names?
                                          Noel Carboni Community Member

                                          Grant H wrote:

                                           

                                          thats just got to do with copying/duplicating of layers... not file names.

                                           

                                          Grant's right; I just changed that setting and tested the action again.  No difference - "copy" is still added.

                                           

                                          -Noel

                                          • 19. Re: How to stop adding " copy" to file names?
                                            JJMack MVP

                                            jacquilynw wrote:

                                             

                                            JJMack:

                                            I don't know anything about PS scripting, I've never tried to use it, what I need can be done via actions, and I don't have a week to stop and learn a new langauge.

                                            Like you don't need to be a programmer to use Photoshop you do not need to program a script to use a script. Photoshop ships with some scripts and some of photoshop functions are implmented using Photoshop scripts. Photoshop Plug-in Fit Image, Function like Photomerge, lens correction,  Some of the scripts the ship with photoshop are: Image Processor, Load Files into Stack, Export Layers To Files and others. You can also dowload script to use from the web for exampl Image Processor Pro.

                                             

                                            Actions have some limitations and sometims Photoshop behavior may not be what one expects.  The Batch processor  (menu File>Automate>Batch) has a dialog that can batch an action and can override some step in an action like save as.  Photoshop has a huge learning curve. You can accomplish some things using many different methods with Photoshop.   Using features like Batch and Image Process can allow you to create simpler actions without having any save step in the action. Batch can overwrite source image files where the Image Processor will not for it is programed to save new image file and leave the original source images files or documents alone. The Image processor can process open documents, image files selected in the bridge or a source image folder or source image tree. All Photoshop supported image file types in a source folder or tree will be process other files will be skiped some like sidecar files may be used if their assocated raw file is in the source folder or sub folder.

                                            • 20. Re: How to stop adding " copy" to file names?
                                              jacquilynw Community Member

                                              I've used things like photomerge before, that think was clunky as all heck. I don't mind the limitations of actions. I didn't need anything that fancy, just simple things over and over.

                                               

                                              I've been using PS since PS 7. I have climbed major parts of PS's learning curve, so I'm aware of it; however, this project has a deadline, and I don't have time to learn something I've never touched before at this point. I like that the actions are layed out in the actions pannel where I can see them, change them, or use them later (since they're auto-saved). The actions can also be told to save over the source files or not depending on what I tell it, all based on a source folder. Actions are easy to customize to process my images the way I need them processed, no matter what that is. Getting a script to do just this simple little thing I need can be much more complex sometimes. Honestly it's rare that I use PS for processing many pictures at once anyway, my most common use for PS is digital painting as a hobby. That's why usually I don't usually have a source image/s to work from, I usually start with a blank white canvas, some layers, the brush tool, and my tablet.

                                               

                                              Besides, your point is mute now. Yesterday I used the action to save out the source jpg's as re-sized psd's in a different folder, I went through and nudged the few that needed it, and I batch ran the other action to save out the psd's as jpg's in yet another folder. If the person who assigned this to me really has a problem with the 'copy' in the file name, then I'll just download the free trial of total comander and run a quick find and replace to remove it from every file in a matter of seconds. I would still like PS to stop adding copy to file names when using actions though for anything I have to do later on.

                                              • 21. Re: How to stop adding " copy" to file names?
                                                jaleesapowell Community Member

                                                I used "Save for web and devices" instead of "Save As" while creating my action and that worked pretty well. None of my files have that annoying "Copy" added into the file name and they are all saved as JPEGs .

                                                • 22. Re: How to stop adding " copy" to file names?
                                                  ikumajap Community Member

                                                  This works but a bit messy.

                                                   

                                                  >Select all

                                                  >Copy all layer

                                                  >New window (New file window)

                                                  >Paste

                                                  >Save as

                                                  >Select file name and save

                                                  • 23. Re: How to stop adding " copy" to file names?
                                                    Rhexin Community Member

                                                    ikumajap's response made me realize the reason the "save as copy" is greyed out is because it has layers. So all you have to do is add a "flatten image" action first, then a new "save as jpg" that does not include the copy. I tried adding flatten to my old action but it still added "copy" so you do have to make a new save action. This, of course, will not alter your original file as long as you don't add a plain old save in there first.

                                                     

                                                     

                                                     

                                                     

                                                    English (auto-detected) » English
                                                    • 24. Re: How to stop adding " copy" to file names?
                                                      RubyAbey Community Member

                                                      Hey everyone, I found a solution for this, You just have to choose "Save for web and Devices" instead of "Save As" ..then select,JPEG ( or whatever the file extension you need) and then hit save. And the file name will not be changed, so please remember to give a new location while recording the action.

                                                      • 25. Re: How to stop adding " copy" to file names?
                                                        jules_1973 Community Member

                                                        Doing that Ruby will remove the path if you need it in the JPG

                                                        • 26. Re: How to stop adding " copy" to file names?
                                                          drukkerijgerja Community Member

                                                          Did anyone found a solution to this problem? 

                                                          • 27. Re: How to stop adding " copy" to file names?
                                                            Kungfauxn00b Community Member

                                                            This works for me in CS6...

                                                             

                                                            Ctrl + Alt + S = Save: As a Copy TICKED

                                                            Ctrl + Shift + S = Save: As a Copy UNTICKED

                                                             

                                                            HTH.

                                                            • 28. Re: How to stop adding " copy" to file names?
                                                              Gb84 Community Member

                                                              Remove all alpha channels from the channels options. Once removed it allows you to save out a jpg without adding the "copy".

                                                              • 29. Re: How to stop adding " copy" to file names?
                                                                JoeLib Community Member

                                                                Are you using Photoshop Elements?  A friend of mine using Photoshop Elements sends me JPGs and every one of the file names has "copy" in them.

                                                                • 30. Re: How to stop adding " copy" to file names?
                                                                  Gb84 Community Member

                                                                  I'm using Photoshop CS6/CC. If the image isn't flattened the default for Photoshop is to append "copy" to the end of the file name. In my instance I flattened the file but the alpha channel was preventing it from saving without copy.Once channel removed it saved out perfectly

                                                                  • 31. Re: How to stop adding " copy" to file names?
                                                                    Jeegurda Community Member

                                                                    Okay, since this is still not resolved in almost 2015, gonna add my solution here. Actually i never found consistency about this auto-adding ' copy' behavior, it may suddenly stop doing this even if you use that legacy 'Save as copy' menu via cmd/ctrl+ALT+S shortcut (which should be removed already in CC 2014) with a checkbox 'As a copy' already checked, which causes the problem, as some users here have suggested.

                                                                    But i found that is STILL adds ' copy' every time even if i use cmd/ctrl+SHIFT+S when recording an action to save as .png. The solution i found is that your .psd and .png file must have different names (to be 100% sure even put them in different folders), then it works as i want it to.

                                                                    I have a icon_sprite.psd file in my website root folder and just want to update sprite.png in /images folder, without flatting it out, removing layers and stuff, that really makes no sense. Recorded an action pointing to /images directory, saving with a different name, and FINALLY it worked, it just overwrites /images/sprite.png as it should, without adding ' copy'.

                                                                    I guess there is a bug which make PS think like there is a file with that name already, and it adds ' copy', because this is the file being edited. But this is incorrect, since it doesn't look at the extension.

                                                                    May be you don't even have to put both files in separate folders, but like i said there's no consistency, so i can't be sure. May be it'd get fixed in CC 2020.

                                                                    • 32. Re: How to stop adding " copy" to file names?
                                                                      lakshmanr75052612 Community Member

                                                                      Hi, for anyone who is having the same problem I think I have solved it.  If you set a Destination in the Automate - Batch menu, that'll save without the copy.  Worked for me anyway.  Cheers

                                                                      • 33. Re: How to stop adding " copy" to file names?
                                                                        fgallery2 Community Member

                                                                        I'm pretty sure I found a quirk (bug?) in Photoshop CS6 regarding the Save As Copy inconsistency when using automation. Setting a destination in automation will not always work.   If you open a PSD file that is flat, automation that saves with dialog will not restrict to the 'as a copy' mode.  With layered PSD files, even if flattened just before using automation, saving will be forced to the 'as copy mode', and the save destination will not be remembered for the next save.

                                                                        I would argue that since I am saving a .jpg every time with my automation, that I should not have this enforcement.  When I want to save the same file to more than one location with automation (with dialog enabled) Not only do I have to rename the file again, but I have to navigate again to a far away folder.

                                                                        This restrictive behavior is not enforced on files that were already flattened before opening, or on new files created, flattened and saved.  I suppose there is not great way to handle all of this, but I would think if I'm saving .jpgs I should be able to do whatever I want, since this is not my source image.