3 Replies Latest reply on Feb 10, 2012 9:12 AM by 3funovic

    locally works - not online

    3funovic

      I really hope someone can give me, at least hint...

       

      My client switched to Akamai (OnStream Media) and I have serious problems to run our old osmf player, to work properly with rtmp MBR streaming (mp4 files).

      To cut short, after first successful switch to next bitrate, streaming fails.

       

      Log:

      Tue Feb 7 2012 02:48:35 PM [DEBUG] [org.osmf.net.rtmpstreaming.SufficientBandwidthRule] Move up since avg dropped FPS 0 < 2 and bufferLength > 1

      Tue Feb 7 2012 02:48:35 PM [DEBUG] [org.osmf.net.rtmpstreaming.SufficientBandwidthRule] getNewIndex() - about to return: 4, detail=null

      Tue Feb 7 2012 02:48:35 PM [DEBUG] [org.osmf.net.NetStreamSwitchManager] checkRules() - Calling for switch to 4 at 1300 kbps

      Tue Feb 7 2012 02:48:35 PM [DEBUG] [org.osmf.net.NetStreamSwitchManager] executeSwitch() - Switching to index 4 at 1300 kbps

      Tue Feb 7 2012 02:48:44 PM [INFO] [org.osmf.net.NetStreamLoadTrait] NetStream.Failed

      Tue Feb 7 2012 02:48:44 PM [DEBUG] [org.osmf.net.NetStreamSwitchManager] onNetStatus() - event.info.code=NetStream.Failed

      Tue Feb 7 2012 02:48:44 PM [INFO] [org.osmf.net.NetLoader] Stream reconnect: onNetStatus: NetStream.Failed

       

      And no matter what kind of plug ins, or different HDCore factories I've tried - it fails, same in all cases.

       

      Then I switched to http streaming, and smil usage.

      And after whole process of getting it to work properly for whole set of client's needs, it works superb locally (in flash IDE)

       

      But tested online - it fails to start streaming.

      Tracing mediaPlayer.state in this case gives following result:

      loading,

      ready,

      playbackError.

       

      Any hint?

      Thanks in advance.

        • 1. Re: locally works - not online
          charles_newman

          There is some confusing information here.  I see the rtmpstreaming package being used and then you mention "Then I switched to http streaming, and smil usage.".

           

          For your rtmp streams, try each individual stream url and see if you can stream them individually. If you are connected to a remote server from the Flash IDE and everything works, this might suggest a security setting on the server. Perhaps the crossdomain.xml file is not allowing connections from the host where your player is mounted.

           

          If all else fails, have your client contact Akamai CCare. This should be a very quick resolution.

           

          Thanks,

          - charles

          • 2. Re: locally works - not online
            3funovic Level 1

            Hey Charles,

            thanks for quick response.

             

            Yes, I believe I put it confusingly first time, so to clear out...

             

            RTMP:

            First, encoding of video files isn't issue here, since we copied already used files from our old provider.

            And yes, I've tried streaming any single bitrate - without any problem.

            Problem exist only with MBR.

            I'm using old, standard approach, adding single bitrates manually to DynamicStreamingResource, and then using that directly with video element or giving it to some factory.

            I've tried all possible combinations of different factories, loaded plugins, or anything else that I could came up as possible solution.

            But player runs same in all cases. Even simplest one, without anything - just basic code to get mbr streaming.

            Also, there's no difference in testing it locally from IDE or online, from different locations.

             

            HTTP:

            I switched to this approach just because I had no solution for desired rtmp streaming.

            After all, I end up with DefaultMediaFactory and Advanced Akamai Plugin, which works great in IDE (except it needs much more time to generate proper element and start streaming), so at least I had some result.

            But putting it online, anywhere, brings mentioned problem.

            I already checked crossdomain policy (http://origin-hdf.onstreammedia.com/crossdomain.xml) and it looks fine to me.

            Also, I already contacted help desk of our new provider, but those guys aren't really into flash subjects - so I'm getting only general set of usual advices from them.

             

            Thanks again, I really appreciate.

            • 3. Re: locally works - not online
              3funovic Level 1

              I just received info that AkamaiHD network do not support dynamic mbr streaming over RTMP protocol.

              That's why my switching fails in any variant I've tried.

               

              So just to inform anyone here, and prevent someones lost time.