4 Replies Latest reply on Mar 26, 2012 9:22 AM by Ginger519

    frozen left pane TOC in merged WebHelp (RH9)

    Ginger519

      We have a merged webhelp project, using RH9 and the non-grainge model, all sub projects (children) TOC links work fine in the left pane except one. That one has many links within the project and has been imported from RH8 into the RH9 merged set up and is a large project. After clicking a few links in the right pane topics, the left pane freezes and none of the books will open or close. If the books were already open whether in this project or anyof the other child projects, the links will work but the auto-sync function does not work. I even created a grainge-style model of the parent/child and the same issue happens. What is causing this? We had this same left pane TOC freeze whenever we tried to put buttons in the skin of the parent going to the other child projects "home" pages.

      Thanks,

      Gigi

        • 1. Re: frozen left pane TOC in merged WebHelp (RH9)
          Peter Grainge Adobe Community Professional (Moderator)

          I'm flattered it is now necessary to indicate when my method is not being used.

           

          I am not sure I am following the issue here so let me check. You have a parent project that has content and you have a number of child projects, one of which is a rogue. So if you don't touch the TOC for that child or access any of its topics via any other links, the merge is otherwise OK. The problem only occurs when you access that child's topics in the right hand topic pane and start clicking links. Correct so far?

           

          If you open that child project using its start page, does the problem occur then?

           

          Does the problem still occur if you use a supplied skin in all the projects rather than your customised skin?

           

          Do all the projects have the same language set at project level?

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: frozen left pane TOC in merged WebHelp (RH9)
            Ginger519 Level 1

            1.     The problem does not start immediately when you click the start page of the rogue project, after a few clicks inside some of the topics then it freezes the left pane.

             

            2.     I tried using the “default” skin on the parent (which all the child projects have selected when they are compiled) and the same issues happens after a few clicks on links within the topics of the rogue project.

             

            3.     Yes, all the projects are set in English.

            Thanks so much,

            Gigi

            • 3. Re: frozen left pane TOC in merged WebHelp (RH9)
              Peter Grainge Adobe Community Professional (Moderator)

              Have you tried more than one browser?

               

              Have you tried viewing from more than one machine?

               

              Have you checked you haven't accidentally set the output to WebHelp Pro?

               

              Have you tried generating all the projects to a new location?

               

              Sorry but this is not a problem I have seen before so it's a trial and error approach.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge

              • 4. Re: frozen left pane TOC in merged WebHelp (RH9)
                Ginger519 Level 1

                Work around was to set links (not the TOC placeholders) from the parent home page to another page in child project and not to the "start" page. I made a second topic with a different file name to act as the "home" page of the child project when pointing a link to the child project from the parent project. Apparently by pointing to the "start" page is when I would get the second left pane showing up next to the merged parent left pane TOC.

                I hope this helps anyone who ends up having this problem.

                Gigi