4 Replies Latest reply on Feb 13, 2012 12:14 PM by Rik Ramsay

    ID CS5.5 book creates weird page flow in PDF

    John Philpit Level 1

      I am using ID version 7.5.2 and Acrobat 9 Pro Extended (version 9.5.0).


      I created an InDesign book (indb) that condains an indd file for each chapter. There are about 20 chapters so far, typically 4 to 7 pages each. The documents all use the same 2-page spread. The page numbering is automatic. And the document setup dialog has "facing pages" checked.


      When I use the default preset in the File menu to create a PDF (using all default settings, no changes in the dialog), it successfully creates the PDF, but the flow of pages is not as expected. Specifically, Acrobat and Reader seem to be treating each 2-page spread (when in the same indd file) as a page. With Page Display set to "Single Page View," Reader shows me page one alone and then pages 2 and 3 side by side. And so on, so that whenever a 2-page spread is from a single indd file, Reader treats them as one page. And when pages which should face each other are from different indd files, they appear separately, one below the other.


      Other types of Page Display settings give similar weird behavior. For example, "Two Page View" might show pages 20 and 21 as the left page and pages 22 and 23 as the right page as long as all of that content comes from the same indd file.


      Any ideas about what I'm doing wrong? Or, alternatively, is there anything I can do in the full Acrobat to get the display behavior back to the usual facing-page format?


      Note that I have been using ID for many years, but have not used the Book feature (indb file) recently. I'm using the Book feature this time because I plan to create an EPUB and I understand that the easiest way to force each chapter to start at the top of a page is to put each chapter in its own indd within a book.


      Thanks in advance for any assistance.



        • 1. Re: ID CS5.5 book creates weird page flow in PDF
          Peter Spier Most Valuable Participant (Moderator)

          Are you exporting to PDF (interactive) or PDF (Print)?


          The former exports spreads by default, and you can only change that by script.


          If you go to http://indesignsecrets.com/interactive-pdf-from-indesign-cs5-always-has-spreads-on.php you'll find a number of soultions, but the best is this one-line script from Harbs down in the comments:


          app.interactivePDFExportPreferences.exportReaderSpreads = !app.interactivePDFExportPreferences.exportReaderSpreads

          • 2. Re: ID CS5.5 book creates weird page flow in PDF
            Rik Ramsay Level 4

            Could you simply have left the "spreads" box checked when exporting the pdf? If so, uncheck this and it should export as expected.


            • 3. Re: ID CS5.5 book creates weird page flow in PDF
              John Philpit Level 1

              Thanks, Peter and Rik,

              With your help it's working 90% correctly. I didn't notice at the bottom of the dialog where I'm asked for the file name to save as that it was defaulting to PDF (Interactive). Once I changed it to PDF (Print), I started seeing consistent 2-page spreads in Reader/Acrobat when I set Page Display to 2-page.


              One small step to go. I'd like to see all odd-numbered pages on the right, as in a printed book (even though that means the first spread in Reader will have no page on the left). That behavior will put the page numbers at the outside edge and not near the gutter.


              I've tried setting "Next Odd" in the Book Page Numbering Options dialog but, as expected, that made every chapter begin on an odd-numbered page. I just want the first indd to start on an odd page.


              I've also tried toggling the Spreads checkbox and the Facing Pages checkbox, but changes there only make matters worse.


              Bottom line: where can I tell InDesign (or Acrobat, if necessary) to always show page 1 and all odd-numbered pages on the right when Reader is in 2-page display mode?

              • 4. Re: ID CS5.5 book creates weird page flow in PDF
                Rik Ramsay Level 4

                If you are in 2 page view, turn on "show cover in 2 page view"




                This puts the cover on its own page.


                Alternatively, contrary to what I told you last time, you could turn ON spreads and then export as a normal PDF then turn off 2 page view. This should then have the cover on one page and the following spread as 2 pages in the window.


                If you have any InD documents with odd numbers of pages, you might need to add in a blank page at the end to get the positioning correct for the rest fo the book. eg. If first InD file is 4 pages but second is 5, the 3rd file will start on the wrong side.