17 Replies Latest reply on Feb 16, 2012 8:51 AM by Omar Saleh

    Discarding The Pasted Text Format

    Omar Saleh Level 1

      Hello

      i am facing problem with text, i have PDF and Word docs which i am using the text from.

      when i copy for example some text in the InDesign CS 5.5 doc, some "Question Marks" or extra spaces between the words appears as rectangle.

       

      i tried to copy and paste the text in text field, so there will be no formatting, but the "Question Mark" appears as well.

       

      any idea

       

      thanks

        • 1. Re: Discarding The Pasted Text Format
          Stix Hart Level 5

          Have you tried "Paste without formatting"?  Use the Edit menu, right click, or use the short cut to see it.

          • 2. Re: Discarding The Pasted Text Format
            lilia@ Level 2

            in acrobat pro (assuming you have it)... try... file > export > text

            • 3. Re: Discarding The Pasted Text Format
              [Jongware] Most Valuable Participant

              It has nothing to do with formatting (the OP said it also does this when pasting into a text field, which is a good way to make sure all formatting is gone).

               

              Omar, literal question marks, or are those in fact "missing glyphs" indicators? The latter ones are marked by InDesign with a pink background; and if so, these characters simply are not available in the font that you are using. Go through your font list until you find one that works, or alternatively, select one of these characters and look in the Info panel for its Unicode value is, then check with a web site such as FileFormat.info (http://www.fileformat.info/info/unicode/char/2212/index.htm -- per character there is a link "Fonts that support XXX") -- or ask us

               

              If you find that these marks are actual "question marks" then there is nothing you can do about it. Text copied out of Word or PDF comes into ID as-is, you cannot change some setting to alter it.

              1 person found this helpful
              • 4. Re: Discarding The Pasted Text Format
                Omar Saleh Level 1

                Thnaks so much your all support

                 

                Stix Hart,

                i tried "Paste without formatting", but it is gray even when my insertion point inside text field, i do not why

                 

                 

                lilia@.,

                i have Pro version, i did your way, the program give me an error:

                Unable to convert untagged document to Tagged PDF.

                 

                while exporting i chose text > plain text without anything in the setting only the text

                 

                 

                [Jongware],

                it is "missing glyphs", yes it is with pinked background.

                i did choose different fonts, but these glyphs still there

                i used the link, it does not there, i did search and find this:

                http://www.unicodemap.org/details/0xFFFD/index.html

                it seems i have to get special update from microsoft for my Windows 7, i got one for Exchange Server 2007 Service Pack 3

                http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=20935

                i do not know if it will will work on my machine or not

                 

                i appreciate your time and hope i can get extra info about this situation

                • 5. Re: Discarding The Pasted Text Format
                  [Jongware] Most Valuable Participant

                  A-ha. U=FFFD is not a normal character at all, and can safely be deleted from your text. The Unicode name is "Replacement Character" and Its sole purpose is to identify 'somethingsomething comes here that's not text'. InDesign uses this code, for example, as a placeholder for XML codes and hyperlinks. Of course you (the user) don't need to know that, so when InDesign inserts one itself, it looks up the correct code and displays the correct information.

                   

                  In your case it seems these codes were accidentally included in the exported plain text stream. Nothing you can do about that, you cannot choose not to copy them; but it's perfectly alright to delete them.

                  • 6. Re: Discarding The Pasted Text Format
                    Omar Saleh Level 1

                    How can i delete them, when i copy from PDF and paste in InDesign CS 5.5, it is there, many many of them.

                    i am dealing with it manually. select and delete, this will take a lot of time.

                     

                    i selected the glyph and opened find and replace, to find all these glyphs and delete them, but was not able.

                     

                    any direction how to do that?

                     

                    thanks so much for your time

                    • 7. Re: Discarding The Pasted Text Format
                      Omar Saleh Level 1

                      sorry, i forgot to say, when i copy these glyph and paste them in the find window, it becomes empty space, i do not see any thing.

                      • 8. Re: Discarding The Pasted Text Format
                        Omar Saleh Level 1

                        in the menu, i found this info:

                        Clear recently used glyphs

                        • To clear a selected glyph from the Recently Used section, right-click (Windows®) or Control-click (Mac OS) a glyph in the Recently Used section, and then choose Delete Glyph From Recently Used.
                        • To clear all recently used glyphs, choose Clear All Recently Used.

                         

                        i did not find this command:

                        Delete Glyph From Recently Used

                        • 9. Re: Discarding The Pasted Text Format
                          Peter Spier Most Valuable Participant (Moderator)

                          Clearing recently used glyphs removes them from the list at the top of the Glyphs panel, not from youf document, so is of little use here.

                           

                          Did you try using find change to remove them? I'd use the GREP tab and paste one in the find field, leave everything else blank, and change all.

                          • 10. Re: Discarding The Pasted Text Format
                            Omar Saleh Level 1

                            Hello Peter

                            i did before, the problem is copying one of these glyphs and pasting in the find field show empty space, not the glyph itself

                            • 11. Re: Discarding The Pasted Text Format
                              Peter Spier Most Valuable Participant (Moderator)

                              Did you actually try the replace after pasting? I understand there may not be anything showing.

                              • 12. Re: Discarding The Pasted Text Format
                                Omar Saleh Level 1

                                Yes, and when i try Find Next command, it jumps to any space in the text ignoring the glyph

                                • 13. Re: Discarding The Pasted Text Format
                                  Peter Spier Most Valuable Participant (Moderator)

                                  Sorry, had to run out..

                                   

                                  Here's another approach that might work:

                                   

                                  Export to InDesign tagged text. You should be able to open that in a plain text editor and find an instance of the problem character (you already know where it is), so you ought to be able to copy any code for that, if it's actually still there, and use find/change inthe text editor to either delete it, or change it to somthing like a string of ***** that shouldn't otherwise be in the text, but that ID WIIL find in Find/Change. Re-import the tagged text.

                                  • 14. Re: Discarding The Pasted Text Format
                                    Joel Cherney Adobe Community Professional & MVP

                                    i did before, the problem is copying one of these glyphs and pasting in the find field show empty space, not the glyph itself

                                     

                                    Hey Omar, you're not working with English text, are you?  I suspect you're trying to copy/paste complex script text (Arabic/Persian/Urdu/etc) in an unusual font from Word or PDF; there are special problems with such languages when copying and pasting, especially from PDF.

                                     

                                    i tried "Paste without formatting", but it is gray even when my insertion point inside text field, i do not why

                                     

                                    It means that the contents of your clipboard are already raw text without formatting.  There's a special setting in your Preferences for copying & pasting from programs like Word; you have a choice between keeping the formatting and style and such with the text on the clipboard, or just copying and pasting raw text. Sounds like you have the raw text setting. However,

                                     

                                    How can i delete them, when i copy from PDF and paste in InDesign CS 5.5, it is there, many many of them.

                                    i am dealing with it manually. select and delete, this will take a lot of time.

                                     

                                    If I understand you correctly, you're copying text out of PDF or Word, and when pasting it into ID you're getting that question-mark Unicode-replacement glyph in your text. That means that whatever glyph is in your source is getting broken or lost when text is being placed in your clipboard.

                                     

                                    I think it might help a lot if you could post your source text (if you're allowed to) in PDF and/or WOrd to a place like Dropbox or YouSendIt so we can download it and look at it. If I'm right and you're working with complex-script right-to-left text, it's really hard to copy and paste. Sometimes it's impossible to copy complex-script text out of PDF and get anything usable, for a wide variety of reasons.

                                    • 15. Re: Discarding The Pasted Text Format
                                      [Jongware] Most Valuable Participant

                                      Finally found a way to insert an <FFFD> character into ID -- so now I could find out how to find it again.

                                       

                                      Copy-paste into the Find What field indeed doesn't work (which is weird), but typing in the Unicode does. Search for

                                       

                                      <FFFD>

                                       

                                      and replace with whatever you like. In the GREP it's a different notation, in there you would use this

                                       

                                      \x{FFFD}

                                      • 16. Re: Discarding The Pasted Text Format
                                        Omar Saleh Level 1

                                        Hello Joel

                                        Yes, i am using Arabic PDF doc

                                        i will upload to Dropbox

                                        how can i send it to you?

                                         

                                        regards

                                        • 17. Re: Discarding The Pasted Text Format
                                          Omar Saleh Level 1

                                          wow [Jongware], great job man

                                          it is really complicated to find way like this

                                          it works with perfectly

                                           

                                          many many thanks to every one tried to help