6 Replies Latest reply on May 24, 2008 1:12 AM by Peter Grainge

    issues with the TOC and index

    Boggym Level 1
      I am doing localization for Japan, so I got everything nice and proper in Japanese (topics, TOC and indexes), however, after compilation the TOC and indes are in a font that does not support Japanese characters.
      Does anybody have any ideas how to solve this?
      Thank you
        • 1. Re: issues with the TOC and index
          RoboColum(n) Level 5
          Hi Boggym and welcome to the RH community.

          This sounds like you need to open your single source layout and click on the Advanced button in the first page. In there are two tabs that allow you to specify the font for the TOC and Index.
          • 2. Re: issues with the TOC and index
            Boggym Level 1
            I already did that, and did not help.
            All the content is OK, I can see it in Japanese, however the TOC and indes is illegible in any language.
            • 3. Re: issues with the TOC and index
              Boggym Level 1
              I forgot to thank you for your quick answer Column McAndrew, sorry!
              Thank you!
              • 4. Re: issues with the TOC and index
                Pete Lees Level 2
                Hi, Boggym,

                If this is HTML Help (.chm), are you compiling on a machine that is either running Japanese Windows or has the appropriate language files installed and the system default language set to Japanese? See this article:

                http://helpware.net/FAR/far_faq.htm#JapComp

                Pete
                • 5. Re: issues with the TOC and index
                  Boggym Level 1
                  Thank you very much Pete, this was a part of the solution.
                  Actually, what I found out on a German forum for RoboHelp, is that one has to set the machine on the regional settings for the country for which the localisation is being done. I installed the support language pack previous to my problem and so I was able what I was translating in the topics. The problem appeared when I tried my first compilation. The topics were still in Japanese, as I translated them, however the TOC and the index were the only ones which were in a totally unknown writing style (not Japanese and not English and not any other language I know).
                  Right now as I changed the localisation of my system, it works.
                  So, I think this should be a first improvement for RoboHelp, right? They brag that they support 35 languages, however the support is not quite... complete, eh?
                  By the way, the error message keeps coming even after all those changes, however I do not care too much about it, as I get what I need.
                  Thank you again Pete for the solution and the fast answer.
                  • 6. Re: issues with the TOC and index
                    Peter Grainge Adobe Community Professional (Moderator)
                    I think that is more to do with how the Microsoft help compiler works than what RH generates.